summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-07-13 15:07:56 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-07-14 17:14:52 -0300
commit4d1b16be20bc4054d8da6d32fe813d4048c5a04f (patch)
treefc23bccf8fbf48ad00b9738e8baced67a8afb388
parent0db51a0c6cd25eaf3328afbe5b352e3ea35528e0 (diff)
downloadmeta-freescale-4d1b16be20bc4054d8da6d32fe813d4048c5a04f.tar.gz
hypervisor:fix build error with gcc7
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch40
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch b/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch
new file mode 100644
index 00000000..1100ab6e
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch
@@ -0,0 +1,40 @@
1From 51f545b9c16f6a371c129bd0fbb9c7f7ae339df3 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 13 Jul 2017 13:59:28 +0800
4Subject: [PATCH] fix build error gcc7
5
6
7Upstream-Status: Pending
8
9---
10 Makefile.build | 7 ++++---
11 1 file changed, 4 insertions(+), 3 deletions(-)
12
13diff --git a/Makefile.build b/Makefile.build
14index e93cc9a..f6028fe 100644
15--- a/Makefile.build
16+++ b/Makefile.build
17@@ -35,7 +35,8 @@ GENASSYM=$(libos)lib/genassym.sh
18
19 export libos := $(src)libos/
20
21-export CC=$(CROSS_COMPILE)gcc
22+
23+
24
25 export GCCINCDIR := $(shell $(CC) -print-file-name=include)
26 CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-fixed \
27@@ -46,8 +47,8 @@ CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-f
28 export CC_OPTS_NODEP := -include include/config/autoconf.h
29
30 export WARNINGS := -Wwrite-strings -Wmissing-prototypes \
31- -Wstrict-prototypes -Wold-style-definition \
32- -Wmissing-declarations
33+ -Wstrict-prototypes -Wold-style-definition -Wno-format-truncation \
34+ -Wmissing-declarations
35
36 # Our code should build without any of these warnings, but some
37 # external code may be excluded.
38--
392.7.4
40
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
index 90cdf2bc..bf904e0a 100644
--- a/recipes-virtualization/hypervisor/hypervisor_git.bb
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -17,6 +17,7 @@ SRC_URI = " \
17 git://git.kernel.org/pub/scm/utils/dtc/dtc.git;name=dtc;destsuffix=dtc \ 17 git://git.kernel.org/pub/scm/utils/dtc/dtc.git;name=dtc;destsuffix=dtc \
18 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;branch=sdk-v2.0.x \ 18 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;branch=sdk-v2.0.x \
19 file://81-fsl-embedded-hv.rules \ 19 file://81-fsl-embedded-hv.rules \
20 file://0001-fix-build-error-gcc7.patch \
20 " 21 "
21 22
22SRCREV_FORMAT="hypervisor" 23SRCREV_FORMAT="hypervisor"