diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-11 09:38:49 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:06:34 -0300 |
commit | 371822ef79390db3aedad308483bf5df653f4c70 (patch) | |
tree | 05370bbf283c5bc05ddc0985119f6f5a7a035739 | |
parent | ed79c4556a348c7085377122ad0bee8617b310c2 (diff) | |
download | meta-freescale-371822ef79390db3aedad308483bf5df653f4c70.tar.gz |
imx-test: Fix build for X11 backend
The root case of the addition of the dependencies on the recipe was
that it were not being correctly included in the .inc file. This fixes
it and remove the duplication.
Change-Id: Ie9ee5fbc2a61915ce109473f5df2b8e88d3966c4
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/imx-test/imx-test.inc | 7 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.4.bb | 13 |
2 files changed, 3 insertions, 17 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc index 3c463c75..1fcb632c 100644 --- a/recipes-bsp/imx-test/imx-test.inc +++ b/recipes-bsp/imx-test/imx-test.inc | |||
@@ -11,10 +11,6 @@ DEPENDS_mx6sx = "virtual/kernel imx-lib" | |||
11 | DEPENDS_mx6ul = "virtual/kernel imx-lib" | 11 | DEPENDS_mx6ul = "virtual/kernel imx-lib" |
12 | DEPENDS_mx7 = "virtual/kernel imx-lib" | 12 | DEPENDS_mx7 = "virtual/kernel imx-lib" |
13 | 13 | ||
14 | DEPENDS_append = " \ | ||
15 | ${@base_contains('DISTRO_FEATURES', 'x11', 'libx11 libxdamage libxrender libxrandr', '', d)} \ | ||
16 | " | ||
17 | |||
18 | LICENSE = "GPLv2" | 14 | LICENSE = "GPLv2" |
19 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 15 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
20 | 16 | ||
@@ -33,6 +29,9 @@ PLATFORM_mx6sx = "IMX6SX" | |||
33 | PLATFORM_mx7 = "IMX7D" | 29 | PLATFORM_mx7 = "IMX7D" |
34 | PLATFORM_mx6ul = "IMX6UL" | 30 | PLATFORM_mx6ul = "IMX6UL" |
35 | 31 | ||
32 | PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" | ||
33 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | ||
34 | |||
36 | # Required so the fixdep binary is generated | 35 | # Required so the fixdep binary is generated |
37 | addtask make_scripts after do_patch before do_compile | 36 | addtask make_scripts after do_patch before do_compile |
38 | do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock" | 37 | do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock" |
diff --git a/recipes-bsp/imx-test/imx-test_5.4.bb b/recipes-bsp/imx-test/imx-test_5.4.bb index de4e5bad..6a12c055 100644 --- a/recipes-bsp/imx-test/imx-test_5.4.bb +++ b/recipes-bsp/imx-test/imx-test_5.4.bb | |||
@@ -2,19 +2,6 @@ | |||
2 | 2 | ||
3 | include imx-test.inc | 3 | include imx-test.inc |
4 | 4 | ||
5 | DEPENDS_mx6q += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
6 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
7 | DEPENDS_mx6dl += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
8 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
9 | DEPENDS_mx6sl += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
10 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
11 | DEPENDS_mx6sx += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
12 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
13 | DEPENDS_mx6ul += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
14 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
15 | DEPENDS_mx7d += "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
16 | ' libx11 libxdamage libxrender libxrandr', '', d)}" | ||
17 | |||
18 | SRC_URI[md5sum] = "46ddd6d1631cc0f7328383e13632d5bb" | 5 | SRC_URI[md5sum] = "46ddd6d1631cc0f7328383e13632d5bb" |
19 | SRC_URI[sha256sum] = "cae6ec9b4d5cc1c402a7683cc8c2c35cccdd9598283caefcea2804baa47a15b6" | 6 | SRC_URI[sha256sum] = "cae6ec9b4d5cc1c402a7683cc8c2c35cccdd9598283caefcea2804baa47a15b6" |
20 | 7 | ||