diff options
author | Yuqing Zhu <carol.zhu@nxp.com> | 2017-06-27 17:10:12 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-06-28 15:21:18 -0300 |
commit | a1c88d1b14e12eda0cfae3a516b3b20244cd6d4d (patch) | |
tree | 1c7f08c6dc76a3de24ca07561bd130f27eb194cb | |
parent | 111997c8d1243f39031841ecb457a3e56fb25877 (diff) | |
download | meta-freescale-a1c88d1b14e12eda0cfae3a516b3b20244cd6d4d.tar.gz |
qtbase: Fix QT5.8 build error "Platform not recognized" in egl header
Gain the platform value through pkg-config
and pass it through QMAKE_CFLAGS_EGL.
Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch | 32 | ||||
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch new file mode 100644 index 00000000..7e625fd1 --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 3f9703fecd670b36030e1093466f6d11b370c19f Mon Sep 17 00:00:00 2001 | ||
2 | From: Yuqing Zhu <carol.zhu@nxp.com> | ||
3 | Date: Mon, 27 Mar 2017 15:33:35 +0800 | ||
4 | Subject: [PATCH] egl.prf: Fix build error when egl headers need platform | ||
5 | definition | ||
6 | |||
7 | Gain the value through pkg-config and pass it through QMAKE_CFLAGS_EGL. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> | ||
12 | --- | ||
13 | mkspecs/features/egl.prf | 6 ++++++ | ||
14 | 1 file changed, 6 insertions(+) | ||
15 | |||
16 | diff --git a/mkspecs/features/egl.prf b/mkspecs/features/egl.prf | ||
17 | index 9fa0c9e..85d5852 100644 | ||
18 | --- a/mkspecs/features/egl.prf | ||
19 | +++ b/mkspecs/features/egl.prf | ||
20 | @@ -1,3 +1,9 @@ | ||
21 | +# egl headers need a definition | ||
22 | +PKG_CONFIG = $$pkgConfigExecutable() | ||
23 | +PKGCONFIG_CFLAGS = $$system($$PKG_CONFIG --cflags egl) | ||
24 | +PKGCONFIG_CFLAGS = $$find(PKGCONFIG_CFLAGS, ^-D.*) | ||
25 | +QMAKE_CFLAGS_EGL = $$PKGCONFIG_CFLAGS | ||
26 | + | ||
27 | INCLUDEPATH += $$QMAKE_INCDIR_EGL | ||
28 | LIBS_PRIVATE += $$QMAKE_LIBS_EGL | ||
29 | QMAKE_CFLAGS += $$QMAKE_CFLAGS_EGL | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index ff120b76..a0bb301f 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -6,7 +6,9 @@ | |||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
7 | 7 | ||
8 | SRC_URI_append_use-mainline-bsp = " file://Environment-variable-enabling-the-workaround-FBO-rea.patch" | 8 | SRC_URI_append_use-mainline-bsp = " file://Environment-variable-enabling-the-workaround-FBO-rea.patch" |
9 | SRC_URI_append_imxgpu2d = "file://0014-Add-IMX-GPU-support.patch" | 9 | SRC_URI_append_imxgpu2d = "file://0014-Add-IMX-GPU-support.patch \ |
10 | file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \ | ||
11 | " | ||
10 | SRC_URI_append_imxgpu3d = " \ | 12 | SRC_URI_append_imxgpu3d = " \ |
11 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 13 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
12 | 'file://0015-Add-eglfs-to-IMX-GPU.patch \ | 14 | 'file://0015-Add-eglfs-to-IMX-GPU.patch \ |