summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-10-09 07:33:08 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-10-10 10:26:56 +0800
commit893acbf19588ab35d6969d37069f74903fbf9f05 (patch)
treef63d558f4c0dbfad597c8f25fddb527a1703d998
parent994d7fc9645d5d81c516f99112034fb755bc45f3 (diff)
downloadmeta-freescale-893acbf19588ab35d6969d37069f74903fbf9f05.tar.gz
asf: build as 64-bit kernel module on e6500
e6500 is built with 32b rootfs/64b kernel, build asf as 64bit too. Fix the below build issue on e6500 core: | DEBUG: Executing shell function do_make_scripts | make: Entering directory `.../tmp/sysroots/t4240qds/usr/src/kernel' | CC scripts/mod/empty.o | scripts/mod/empty.c:1:0: error: -mcmodel not supported in this configuration | make[2]: *** [scripts/mod/empty.o] Error 1 | make[1]: *** [scripts/mod] Error 2 | make: *** [scripts] Error 2 Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--meta-fsl-ppc/recipes-kernel/asf/asf_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
index 6a6917fa..e3fa8962 100644
--- a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
+++ b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
@@ -14,6 +14,25 @@ S = "${WORKDIR}/git/asfmodule"
14 14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} KERNEL_PATH=${STAGING_KERNEL_DIR}" 15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} KERNEL_PATH=${STAGING_KERNEL_DIR}"
16 16
17python () {
18 ma = d.getVar("DISTRO_FEATURES", True)
19 arch = d.getVar("OVERRIDES", True)
20
21 # the : after the arch is to skip the message on 64b
22 if not "multiarch" in ma and "e6500:" in arch:
23 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
24
25 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
26
27 if promote_kernel == "1":
28 d.setVar('KERNEL_CC_append', ' -m64')
29 d.setVar('KERNEL_LD_append', ' -melf64ppc')
30
31 error_qa = d.getVar('ERROR_QA', True)
32 if 'arch' in error_qa:
33 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
34}
35
17do_install(){ 36do_install(){
18 mkdir -p ${D}/usr/driver/asf 37 mkdir -p ${D}/usr/driver/asf
19 cp -rf ${S}/bin/full ${D}/usr/driver/asf 38 cp -rf ${S}/bin/full ${D}/usr/driver/asf