diff options
author | Zhenhua Luo <zhenhua.luo@freescale.com> | 2013-09-24 21:07:37 +0800 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2013-09-24 21:07:37 +0800 |
commit | 4a09f7b300fddc40d22d569347919d8017ed0ff6 (patch) | |
tree | d139b868e56768ad3673f7c683e0c2d9ed9e9d4c | |
parent | 0eb052b1852c4c4c83cdf56ec0c0d868ccfdfcd8 (diff) | |
download | meta-freescale-4a09f7b300fddc40d22d569347919d8017ed0ff6.tar.gz |
u-boot: fix depend race issue of u-boot-NAND.bin build
| /srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/.depend:125: *** missing separator. Stop.
| make[3]: Leaving directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx'
| make[2]: *** [/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/start.o] Error 2
Fixed [Bug 5239].
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch | 38 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/u-boot/u-boot_git.bb | 3 |
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch b/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch new file mode 100644 index 00000000..1ddc6675 --- /dev/null +++ b/meta-fsl-ppc/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | From 301832414369b749918e0d5db850eed19b81c0fc Mon Sep 17 00:00:00 2001 | ||
4 | From: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
5 | Date: Tue, 24 Sep 2013 00:54:40 -0500 | ||
6 | Subject: [PATCH] Fix the depend race issue | ||
7 | |||
8 | | make[3]: Entering directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx' | ||
9 | | /srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/.depend:125: *** missing separator. Stop. | ||
10 | | make[3]: Leaving directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx' | ||
11 | | make[2]: *** [/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/start.o] Error 2 | ||
12 | | make[2]: *** Waiting for unfinished jobs.... | ||
13 | |||
14 | Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
15 | --- | ||
16 | spl/Makefile | 6 +++++- | ||
17 | 1 file changed, 5 insertions(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/spl/Makefile b/spl/Makefile | ||
20 | index 6dbb105..3156d87 100644 | ||
21 | --- a/spl/Makefile | ||
22 | +++ b/spl/Makefile | ||
23 | @@ -185,7 +185,11 @@ $(eval $(call make_u_boot_list, $(obj)u-boot.lst, $(LIBS))) | ||
24 | $(obj)u-boot-spl.lds: $(LDSCRIPT) $(obj)u-boot.lst depend | ||
25 | $(CPP) $(CPPFLAGS) $(LDPPFLAGS) -I$(obj). -ansi -D__ASSEMBLY__ -P - < $< > $@ | ||
26 | |||
27 | -depend: $(obj).depend | ||
28 | +# Explicitly make _depend in subdirs containing multiple targets to prevent | ||
29 | +# parallel sub-makes creating .depend files simultaneously. | ||
30 | +depend dep: $(obj).depend | ||
31 | + for dir in $(SUBDIRS) $(CPUDIR) $(LDSCRIPT_MAKEFILE_DIR) ; do \ | ||
32 | + $(MAKE) -C $(SRCTREE)/$$dir _depend ; done | ||
33 | .PHONY: depend | ||
34 | |||
35 | # defines $(obj).depend target | ||
36 | -- | ||
37 | 1.8.2.1 | ||
38 | |||
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot_git.bb b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot_git.bb index 008e253d..3479b231 100644 --- a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot_git.bb +++ b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot_git.bb | |||
@@ -11,7 +11,8 @@ DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc libgcc" | |||
11 | 11 | ||
12 | inherit deploy | 12 | inherit deploy |
13 | 13 | ||
14 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git" | 14 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git \ |
15 | file://Fix-the-depend-race-issue.patch" | ||
15 | SRCREV = "831b30de4b768f0b3b7dbfa11739b14cea612d7e" | 16 | SRCREV = "831b30de4b768f0b3b7dbfa11739b14cea612d7e" |
16 | 17 | ||
17 | python () { | 18 | python () { |