summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-06-04 19:30:56 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-06-23 08:44:02 -0300
commitbe4bd4650170a5e9c38875809be440daa65aa0aa (patch)
treed6c13b069ae6bfaefc71ea5ca49f717fb56c717d
parentfb3c377da24217614c0e84a738c9e2f61742f54c (diff)
downloadmeta-freescale-be4bd4650170a5e9c38875809be440daa65aa0aa.tar.gz
optee-client: refresh patch applied upstream
PR has been closed upstream with modifications to originally submitted patch. Later implementation implied more modification, which are not compatible with current version, therefore accepted patch has been backported to this fork. Refresh patch file with updated version from upstream. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch38
1 files changed, 29 insertions, 9 deletions
diff --git a/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch
index 3bbf898b..86c360f2 100644
--- a/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch
+++ b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch
@@ -1,23 +1,29 @@
1From ea7e0fba6da734e5f99f84d10d456ceaaed05883 Mon Sep 17 00:00:00 2001 1From 6a600c5637c5446ab3d11eb4304a1dd473ec503e Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com> 2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Sun, 31 May 2020 20:40:25 +0000 3Date: Thu, 4 Jun 2020 19:24:05 +0000
4Subject: [PATCH] flags: do not override CFLAGS from host 4Subject: [PATCH] flags: do not override CFLAGS from host
5 5
6Some build systems set CFLAGS in environment before the build, but they 6Some build systems set CFLAGS in environment before the build, but they
7got overridden by CFLAGS immediate assignment operator. 7got overridden by CFLAGS immediate assignment operator.
8 8
9Replace immediate assignment with append directive, so the former 9Replace immediate assignment with append directive and use override
10definition of CFLAGS gets properly expanded. 10directive, so the former definition of CFLAGS gets passed either from
11command line or via environment is completely expanded (see [1] for
12detailed explanation of override directive and variable append).
11 13
12Upstream-Status: Submitted [https://github.com/OP-TEE/optee_client/pull/211] 14Link: [1] https://www.gnu.org/software/make/manual/html_node/Override-Directive.html
15
16Upstream-Status: Backport [https://github.com/OP-TEE/optee_client/pull/211]
13 17
14Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> 18Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
19Reviewed-by: Jerome Forissier <jerome@forissier.org>
20Reviewed-by: Joakim Bech <joakim.bech@linaro.org>
15--- 21---
16 flags.mk | 2 +- 22 flags.mk | 6 +++---
17 1 file changed, 1 insertion(+), 1 deletion(-) 23 1 file changed, 3 insertions(+), 3 deletions(-)
18 24
19diff --git a/flags.mk b/flags.mk 25diff --git a/flags.mk b/flags.mk
20index 71f3d18..af13495 100644 26index 71f3d18..faabef9 100644
21--- a/flags.mk 27--- a/flags.mk
22+++ b/flags.mk 28+++ b/flags.mk
23@@ -6,7 +6,7 @@ CROSS_COMPILE ?= arm-linux-gnueabihf- 29@@ -6,7 +6,7 @@ CROSS_COMPILE ?= arm-linux-gnueabihf-
@@ -25,10 +31,24 @@ index 71f3d18..af13495 100644
25 AR ?= $(CROSS_COMPILE)ar 31 AR ?= $(CROSS_COMPILE)ar
26 32
27-CFLAGS := -Wall -Wbad-function-cast -Wcast-align \ 33-CFLAGS := -Wall -Wbad-function-cast -Wcast-align \
28+CFLAGS += -Wall -Wbad-function-cast -Wcast-align \ 34+override CFLAGS += -Wall -Wbad-function-cast -Wcast-align \
29 -Werror-implicit-function-declaration -Wextra \ 35 -Werror-implicit-function-declaration -Wextra \
30 -Wfloat-equal -Wformat-nonliteral -Wformat-security \ 36 -Wfloat-equal -Wformat-nonliteral -Wformat-security \
31 -Wformat=2 -Winit-self -Wmissing-declarations \ 37 -Wformat=2 -Winit-self -Wmissing-declarations \
38@@ -15,11 +15,11 @@ CFLAGS := -Wall -Wbad-function-cast -Wcast-align \
39 -Wpointer-arith -Wshadow -Wstrict-prototypes \
40 -Wswitch-default -Wunsafe-loop-optimizations \
41 -Wwrite-strings -Werror
42-CFLAGS += -c -fPIC
43+override CFLAGS += -c -fPIC
44
45 DEBUG ?= 0
46 ifeq ($(DEBUG), 1)
47-CFLAGS += -DDEBUG -O0 -g
48+override CFLAGS += -DDEBUG -O0 -g
49 endif
50
51 RM := rm -f
32-- 52--
332.17.1 532.17.1
34 54