diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-10-18 13:06:42 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-18 11:42:30 -0200 |
commit | 4434639d39e2649db08b3d06636b7e7e298a9b7c (patch) | |
tree | f175de92c70b23a78ed39b79970d4de6d770803d | |
parent | cab0d505847ee353bc5b0808cccdd3ca80e7cb0b (diff) | |
download | meta-freescale-4434639d39e2649db08b3d06636b7e7e298a9b7c.tar.gz |
uboot: upgrade to 2017.09
*This includes the following changes:
503eff0 - armv8: ls1046aqds: Fix NAND offset for Fman ucode and env
c66ddf7 - arm64: ls2088ardb: Fix kernel validation failure
44ffe98 - armv8: ls1043ardb: disable PPA loading during SPL stage for SD boot
043c85a - armv8: ls1046ardb: disable PPA loading during SPL stage for SD boot
b68c991 - armv8: fsl-layerscape: Fix some coding style problems in soc.c
25cd705 - board/ls1088: Add fsl_fdt_fixup_flash
85bfc58 - ls1088aqds: Enable IFC and QIXIS in SPL image
96cc4d7 - armv8: fsl-layerscape: Add back L3 flushing for all exception levels
bdf9c1a - fsl-lsch2: csu: correct the workaround A-010315
26aaf13 - armv8/fsl-lsch2: correct QMAN clock
a836f94 - arm64: ls1012ardb: Add distro secure boot support
ef3b345 - arm64: ls1012afrdm: Add distro boot support
2bed40e - arm64: ls1012ardb: Add distro boot support
bb85ef3 - board: common: vid: Move IR chip specific code in flag
806bca8 - board/ls2080ardb: Add mcmemsize variable in default env
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch | 86 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2017.09.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb) | 3 |
2 files changed, 1 insertions, 88 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch b/recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch deleted file mode 100644 index 839cd7df..00000000 --- a/recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch +++ /dev/null | |||
@@ -1,86 +0,0 @@ | |||
1 | fix build error under gcc6 | ||
2 | |||
3 | Fix the following error: | ||
4 | | ../include/linux/compiler-gcc.h:114:30: fatal error: linux/compiler-gcc6.h: No such file or directory | ||
5 | | #include gcc_header(__GNUC__) | ||
6 | |||
7 | Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | --- | ||
11 | include/linux/compiler-gcc6.h | 65 +++++++++++++++++++++++++++++++++++++++++++ | ||
12 | 1 file changed, 65 insertions(+) | ||
13 | create mode 100644 include/linux/compiler-gcc6.h | ||
14 | |||
15 | diff --git a/include/linux/compiler-gcc6.h b/include/linux/compiler-gcc6.h | ||
16 | new file mode 100644 | ||
17 | index 0000000..c8c5659 | ||
18 | --- /dev/null | ||
19 | +++ b/include/linux/compiler-gcc6.h | ||
20 | @@ -0,0 +1,65 @@ | ||
21 | +#ifndef __LINUX_COMPILER_H | ||
22 | +#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead." | ||
23 | +#endif | ||
24 | + | ||
25 | +#define __used __attribute__((__used__)) | ||
26 | +#define __must_check __attribute__((warn_unused_result)) | ||
27 | +#define __compiler_offsetof(a, b) __builtin_offsetof(a, b) | ||
28 | + | ||
29 | +/* Mark functions as cold. gcc will assume any path leading to a call | ||
30 | + to them will be unlikely. This means a lot of manual unlikely()s | ||
31 | + are unnecessary now for any paths leading to the usual suspects | ||
32 | + like BUG(), printk(), panic() etc. [but let's keep them for now for | ||
33 | + older compilers] | ||
34 | + | ||
35 | + Early snapshots of gcc 4.3 don't support this and we can't detect this | ||
36 | + in the preprocessor, but we can live with this because they're unreleased. | ||
37 | + Maketime probing would be overkill here. | ||
38 | + | ||
39 | + gcc also has a __attribute__((__hot__)) to move hot functions into | ||
40 | + a special section, but I don't see any sense in this right now in | ||
41 | + the kernel context */ | ||
42 | +#define __cold __attribute__((__cold__)) | ||
43 | + | ||
44 | +#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__) | ||
45 | + | ||
46 | +#ifndef __CHECKER__ | ||
47 | +# define __compiletime_warning(message) __attribute__((warning(message))) | ||
48 | +# define __compiletime_error(message) __attribute__((error(message))) | ||
49 | +#endif /* __CHECKER__ */ | ||
50 | + | ||
51 | +/* | ||
52 | + * Mark a position in code as unreachable. This can be used to | ||
53 | + * suppress control flow warnings after asm blocks that transfer | ||
54 | + * control elsewhere. | ||
55 | + * | ||
56 | + * Early snapshots of gcc 4.5 don't support this and we can't detect | ||
57 | + * this in the preprocessor, but we can live with this because they're | ||
58 | + * unreleased. Really, we need to have autoconf for the kernel. | ||
59 | + */ | ||
60 | +#define unreachable() __builtin_unreachable() | ||
61 | + | ||
62 | +/* Mark a function definition as prohibited from being cloned. */ | ||
63 | +#define __noclone __attribute__((__noclone__)) | ||
64 | + | ||
65 | +/* | ||
66 | + * Tell the optimizer that something else uses this function or variable. | ||
67 | + */ | ||
68 | +#define __visible __attribute__((externally_visible)) | ||
69 | + | ||
70 | +/* | ||
71 | + * GCC 'asm goto' miscompiles certain code sequences: | ||
72 | + * | ||
73 | + * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670 | ||
74 | + * | ||
75 | + * Work it around via a compiler barrier quirk suggested by Jakub Jelinek. | ||
76 | + * | ||
77 | + * (asm goto is automatically volatile - the naming reflects this.) | ||
78 | + */ | ||
79 | +#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0) | ||
80 | + | ||
81 | +#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP | ||
82 | +#define __HAVE_BUILTIN_BSWAP32__ | ||
83 | +#define __HAVE_BUILTIN_BSWAP64__ | ||
84 | +#define __HAVE_BUILTIN_BSWAP16__ | ||
85 | +#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */ | ||
86 | -- | ||
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb b/recipes-bsp/u-boot/u-boot-qoriq_2017.09.bb index 5bde945d..ed998288 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2017.09.bb | |||
@@ -19,9 +19,8 @@ DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native" | |||
19 | DEPENDS_append_qoriq-ppc = " boot-format-native" | 19 | DEPENDS_append_qoriq-ppc = " boot-format-native" |
20 | 20 | ||
21 | SRC_URI = "git://github.com/qoriq-open-source/u-boot.git;nobranch=1 \ | 21 | SRC_URI = "git://github.com/qoriq-open-source/u-boot.git;nobranch=1 \ |
22 | file://fix-build-error-under-gcc6.patch \ | ||
23 | " | 22 | " |
24 | SRCREV = "6fc2946a7b1973a8221cdfeccd1666f2d8eec467" | 23 | SRCREV = "503eff00a7119d2690a662ed64e83e4782b7d3d9" |
25 | 24 | ||
26 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
27 | 26 | ||