diff options
author | Yuqing Zhu <carol.zhu@nxp.com> | 2017-06-02 13:31:36 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-06-16 18:15:14 -0300 |
commit | c87e1a1c4f4614e1f0c2fd4bf72df107793e9fec (patch) | |
tree | 946820384f3238a1e395d82cfe2b23a108c6b005 | |
parent | 98d57b06d88cb22129bd417a9a3edbaf24612460 (diff) | |
download | meta-freescale-c87e1a1c4f4614e1f0c2fd4bf72df107793e9fec.tar.gz |
gstreamer1.0-plugins-base: Don't set async of custom text-sink to false in gstplaysink
Setting async to false will cause A/V sync problem when seeking.
The preroll needs to use GAP event instead of setting async to false.
Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0003-gstplaysink-don-t-set-async-of-custom-text-sink-to-f.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0003-gstplaysink-don-t-set-async-of-custom-text-sink-to-f.patch new file mode 100644 index 00000000..398c4913 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0003-gstplaysink-don-t-set-async-of-custom-text-sink-to-f.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 7847d85e7f37a4a40e483f3b3095c7f8a9fdf5ee Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingke Wang <mingke.wang@freescale.com> | ||
3 | Date: Thu, 19 Mar 2015 14:15:25 +0800 | ||
4 | Subject: [PATCH 02/13] gstplaysink: don't set async of custom text-sink to | ||
5 | false | ||
6 | |||
7 | Setting async to false leads to A/V sync problem when seeking. | ||
8 | The preroll need to use GAP event instead of set async to false. | ||
9 | |||
10 | Upstream-Status: Inappropriate [i.MX specific] | ||
11 | |||
12 | Signed-off-by: Mingke Wang <mingke.wang@freescale.com> | ||
13 | --- | ||
14 | gst/playback/gstplaysink.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | mode change 100644 => 100755 gst/playback/gstplaysink.c | ||
17 | |||
18 | diff --git a/gst/playback/gstplaysink.c b/gst/playback/gstplaysink.c | ||
19 | old mode 100644 | ||
20 | new mode 100755 | ||
21 | index eaac018..02d019e | ||
22 | --- a/gst/playback/gstplaysink.c | ||
23 | +++ b/gst/playback/gstplaysink.c | ||
24 | @@ -2430,7 +2430,7 @@ gen_text_chain (GstPlaySink * playsink) | ||
25 | G_TYPE_BOOLEAN); | ||
26 | if (elem) { | ||
27 | /* make sure the sparse subtitles don't participate in the preroll */ | ||
28 | - g_object_set (elem, "async", FALSE, NULL); | ||
29 | + //g_object_set (elem, "async", FALSE, NULL); | ||
30 | GST_DEBUG_OBJECT (playsink, "adding custom text sink"); | ||
31 | gst_bin_add (bin, chain->sink); | ||
32 | /* NOTE streamsynchronizer needs streams decoupled */ | ||
33 | -- | ||
34 | 1.9.1 | ||
35 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.10.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.10.%.bbappend index 6137d5e0..e6c080ec 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.10.%.bbappend +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.10.%.bbappend | |||
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
3 | GST_IMX_PATCHES = " file://gstplaybin-remove-flag-deinterlace.patch \ | 3 | GST_IMX_PATCHES = " file://gstplaybin-remove-flag-deinterlace.patch \ |
4 | file://0001-MMFMWK-7030-Linux_MX6QP_ARD-IMXCameraApp-When-Enable.patch \ | 4 | file://0001-MMFMWK-7030-Linux_MX6QP_ARD-IMXCameraApp-When-Enable.patch \ |
5 | file://0002-Remove-dependence-on-imx-plugin-git.patch \ | 5 | file://0002-Remove-dependence-on-imx-plugin-git.patch \ |
6 | file://0003-gstplaysink-don-t-set-async-of-custom-text-sink-to-f.patch \ | ||
6 | " | 7 | " |
7 | 8 | ||
8 | GST_IMX_PATCHES_TO_APPEND = "" | 9 | GST_IMX_PATCHES_TO_APPEND = "" |