summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2020-12-28 18:18:07 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-30 09:41:51 -0300
commit409bbc843991b999f16dc035493eb46823b7fce8 (patch)
tree1f3a5a223c33b41a35f8ce056695051e3a7f744c
parentfce19eb3e0d29fce674634d8c15415abd3447453 (diff)
downloadmeta-freescale-409bbc843991b999f16dc035493eb46823b7fce8.tar.gz
imx-mkimage: allow to be used with mainline bsp for all mx8 machines
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
-rw-r--r--conf/machine/imx8mqevk.conf1
-rw-r--r--conf/machine/imx8qmmek.conf1
-rw-r--r--conf/machine/imx8qxpmek.conf1
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb12
4 files changed, 3 insertions, 12 deletions
diff --git a/conf/machine/imx8mqevk.conf b/conf/machine/imx8mqevk.conf
index 3ff21bd4..327ee0ac 100644
--- a/conf/machine/imx8mqevk.conf
+++ b/conf/machine/imx8mqevk.conf
@@ -48,6 +48,7 @@ ATF_PLATFORM = "imx8mq"
48 48
49# Set imx-mkimage boot target 49# Set imx-mkimage boot target
50IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk" 50IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk"
51IMX_BOOT_SOC_TARGET = "iMX8M"
51 52
52# Set Serial console 53# Set Serial console
53SERIAL_CONSOLES = "115200;ttymxc0" 54SERIAL_CONSOLES = "115200;ttymxc0"
diff --git a/conf/machine/imx8qmmek.conf b/conf/machine/imx8qmmek.conf
index 2b2606a6..41a6bbe0 100644
--- a/conf/machine/imx8qmmek.conf
+++ b/conf/machine/imx8qmmek.conf
@@ -59,6 +59,7 @@ ATF_PLATFORM = "imx8qm"
59IMXBOOT_TARGETS = \ 59IMXBOOT_TARGETS = \
60 "${@bb.utils.contains('UBOOT_CONFIG', 'sd', 'flash', \ 60 "${@bb.utils.contains('UBOOT_CONFIG', 'sd', 'flash', \
61 'flash_flexspi', d)}" 61 'flash_flexspi', d)}"
62IMX_BOOT_SOC_TARGET = "iMX8QM"
62 63
63BOARD_TYPE = "mek" 64BOARD_TYPE = "mek"
64 65
diff --git a/conf/machine/imx8qxpmek.conf b/conf/machine/imx8qxpmek.conf
index e3f5ca45..122c40ce 100644
--- a/conf/machine/imx8qxpmek.conf
+++ b/conf/machine/imx8qxpmek.conf
@@ -59,6 +59,7 @@ IMXBOOT_TARGETS = \
59 "${@bb.utils.contains('UBOOT_CONFIG', 'sd', 'flash', \ 59 "${@bb.utils.contains('UBOOT_CONFIG', 'sd', 'flash', \
60 bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \ 60 bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \
61 'UNKNOWN', d), d)}" 61 'UNKNOWN', d), d)}"
62IMX_BOOT_SOC_TARGET = "iMX8QX"
62 63
63BOARD_TYPE = "mek" 64BOARD_TYPE = "mek"
64 65
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index e73d3074..a5ec9d60 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -39,12 +39,6 @@ do_compile[depends] += " \
39SC_FIRMWARE_NAME ?= "scfw_tcm.bin" 39SC_FIRMWARE_NAME ?= "scfw_tcm.bin"
40 40
41ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin" 41ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin"
42ATF_MACHINE_NAME_mx8qm = "bl31-imx8qm.bin"
43ATF_MACHINE_NAME_mx8x = "bl31-imx8qx.bin"
44ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin"
45ATF_MACHINE_NAME_mx8phantomdxl = "bl31-imx8qx.bin"
46ATF_MACHINE_NAME_mx8dxl = "bl31-imx8dxl.bin"
47ATF_MACHINE_NAME_mx8dx = "bl31-imx8dx.bin"
48ATF_MACHINE_NAME_append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}" 42ATF_MACHINE_NAME_append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}"
49 43
50UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}" 44UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"
@@ -53,12 +47,6 @@ BOOT_CONFIG_MACHINE = "${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG}.bin"
53TOOLS_NAME ?= "mkimage_imx8" 47TOOLS_NAME ?= "mkimage_imx8"
54 48
55IMX_BOOT_SOC_TARGET ?= "INVALID" 49IMX_BOOT_SOC_TARGET ?= "INVALID"
56IMX_BOOT_SOC_TARGET_mx8qm = "iMX8QM"
57IMX_BOOT_SOC_TARGET_mx8x = "iMX8QX"
58IMX_BOOT_SOC_TARGET_mx8mq = "iMX8M"
59IMX_BOOT_SOC_TARGET_mx8dxl = "iMX8DXL"
60IMX_BOOT_SOC_TARGET_mx8phantomdxl = "iMX8QX"
61IMX_BOOT_SOC_TARGET_mx8dx = "iMX8DX"
62 50
63DEPLOY_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 51DEPLOY_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
64 52