summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo M. Duarte <rodrigo.duarte@ossystems.com.br>2023-02-08 17:33:27 -0300
committerRodrigo M. Duarte <rodrigo.duarte@ossystems.com.br>2023-02-13 09:40:58 -0300
commitfc464495e4f39358c0f6ef93d8f94244ea41e591 (patch)
tree5d5e9d9864bf7d3c9c3f27e55cf093e3c6ce6ee0
parent070bb60a84302cb77ff7c51f1d72279bb84cd37a (diff)
downloadmeta-freescale-fc464495e4f39358c0f6ef93d8f94244ea41e591.tar.gz
u-boot-imx: Change the imx bsp override to generic bsp
With the imx bsp override the u-boot-imx does not compile imx-boot-tools. This causes an error in imx-boot because it does not find imx-boot-tools. Signed-off-by: Rodrigo M. Duarte <rodrigo.duarte@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2022.04.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
index 21883af8..361473e7 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
@@ -10,13 +10,13 @@ PROVIDES += "u-boot"
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
12UUU_BOOTLOADER = "" 12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6-nxp-bsp = "${UBOOT_BINARY}" 13UUU_BOOTLOADER:mx6-generic-bsp = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7-nxp-bsp = "${UBOOT_BINARY}" 14UUU_BOOTLOADER:mx7-generic-bsp = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = "" 15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}" 16UUU_BOOTLOADER_TAGGED:mx6-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}" 17UUU_BOOTLOADER_TAGGED:mx7-generic-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
18 18
19do_deploy:append:mx8m-nxp-bsp() { 19do_deploy:append:mx8m-generic-bsp() {
20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
21 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]
22 then 22 then