summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2019-02-21 10:40:19 -0300
committerFabio Berton <fabio.berton@ossystems.com.br>2019-02-21 14:43:03 -0300
commit5eefd89fcf2b634ec35ee3c2169fcb498042d72b (patch)
treee8ccb93bb143308fb40743670e9555c25d969144
parent082fe6a4864de3f0ec14bb5fc53635b653d73891 (diff)
downloadmeta-freescale-5eefd89fcf2b634ec35ee3c2169fcb498042d72b.tar.gz
u-boot-fslc-common: Add bison-native to DEPENDS
U-Boot build depends on bison native. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> (cherry picked from commit ea4c4ad341caf8654423f87b223b262b608cfc85)
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2018.11.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.11.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2018.11.bb2
3 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2018.11.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2018.11.inc
index d1a26352..53496b7b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2018.11.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2018.11.inc
@@ -1,4 +1,4 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2019 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4inherit fsl-u-boot-localversion 4inherit fsl-u-boot-localversion
@@ -6,6 +6,8 @@ inherit fsl-u-boot-localversion
6LICENSE = "GPLv2+" 6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" 7LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
8 8
9DEPENDS += "bison-native"
10
9SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
10 12
11SRCREV = "6e25ce6f3c8568b9618de6569794a29a05e1b7a4" 13SRCREV = "6e25ce6f3c8568b9618de6569794a29a05e1b7a4"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.11.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.11.bb
index abcb5013..a809a3f6 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.11.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.11.bb
@@ -1,7 +1,7 @@
1require u-boot-fslc-common_${PV}.inc 1require u-boot-fslc-common_${PV}.inc
2 2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" 3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils" 4DEPENDS += "mtd-utils"
5 5
6INSANE_SKIP_${PN} = "already-stripped" 6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1' 7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2018.11.bb b/recipes-bsp/u-boot/u-boot-fslc_2018.11.bb
index 6c391ad3..5659e16c 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2018.11.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2018.11.bb
@@ -6,7 +6,7 @@ order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \ 6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming." 7version, or because it is not applicable for upstreaming."
8 8
9DEPENDS_append = " dtc-native bison-native" 9DEPENDS_append = " dtc-native"
10 10
11PROVIDES += "u-boot" 11PROVIDES += "u-boot"
12 12