summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-05-13 08:55:57 -0300
committerGitHub <noreply@github.com>2024-05-13 08:55:57 -0300
commitc42ced2dcf608b2e1b3a25e771003fd5ecba50e4 (patch)
tree28c9b6f5683ef653ba3f59238cd45130bee88870
parent68bd788a084fdd0149988b1ccfb2372536b5042c (diff)
parent8d7d14542748365bca751199f15d775df6701f25 (diff)
downloadmeta-freescale-c42ced2dcf608b2e1b3a25e771003fd5ecba50e4.tar.gz
Merge pull request #1822 from Freescale/backport-1821-to-scarthgap
[Backport scarthgap] ppfe-firmware: Respect nonarch_base_libdir
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index c01bfd4c..bb542e8c 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -13,10 +13,10 @@ SRCREV = "f55ee9f72090309bbb7ab71f48a498fc02909234"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15do_install () { 15do_install () {
16 install -d ${D}/lib/firmware 16 install -d ${D}${nonarch_base_libdir}/firmware
17 install -d ${D}/boot/engine-pfe-bin 17 install -d ${D}/boot/engine-pfe-bin
18 install -m 644 ${S}/NXP-Binary-EULA.txt ${D}/lib/firmware 18 install -m 644 ${S}/NXP-Binary-EULA.txt ${D}${nonarch_base_libdir}/firmware
19 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware 19 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}${nonarch_base_libdir}/firmware
20 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin 20 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin
21} 21}
22 22
@@ -27,7 +27,7 @@ do_deploy () {
27 27
28addtask deploy after do_install 28addtask deploy after do_install
29 29
30FILES:${PN} += "/lib/firmware /boot/" 30FILES:${PN} += "${nonarch_base_libdir}/firmware /boot/"
31INSANE_SKIP:${PN} += "arch already-stripped" 31INSANE_SKIP:${PN} += "arch already-stripped"
32INHIBIT_PACKAGE_STRIP = "1" 32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1" 33INHIBIT_SYSROOT_STRIP = "1"