summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-05-13 07:58:39 -0300
committerGitHub <noreply@github.com>2024-05-13 07:58:39 -0300
commit68bd788a084fdd0149988b1ccfb2372536b5042c (patch)
tree09161aa359c4e6f8a23a4f69af15376ce3983bf4
parentaf91f37f3d4cbc8dfe4c6b76fbffc680e48fac85 (diff)
parent2f8342bcc785b9f01c95a0b695f5583e0924bad7 (diff)
downloadmeta-freescale-68bd788a084fdd0149988b1ccfb2372536b5042c.tar.gz
Merge pull request #1820 from Livius90/master
Sync master to scarthgap
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb23
-rw-r--r--recipes-kernel/linux/linux-fslc_6.6.bb4
2 files changed, 12 insertions, 15 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index 6e31c1e2..9511d654 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -12,8 +12,8 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
12############################################################################### 12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates 13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources: 14# from 3 different sources:
15# 1. Stable [linux-6.1.y] branch updates of korg; 15# 1. Stable [linux-6.6.y] branch updates of korg;
16# 2. NXP-specific updates via branch [lf-6.1.y] shared via GitHub NXP repo; 16# 2. NXP-specific updates via branch [lf-6.6.y] shared via GitHub NXP repo;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above 17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree. 18# sources, but are required to be applied to the kernel tree.
19# 19#
@@ -28,23 +28,20 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v6.1.70 31# tag: v6.6.28
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------ 35# ------------------------------------------------------------------------------
36# tag: lf-6.1.55-2.2.0 36# tag: lf-6.6.3-1.0.00
37# 37#
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - 77a660738af5 Revert "net: stmmac: fix FPE events losing" 41# - f67cb9a5b4fb7 Revert "net: stmmac: fix FPE events losing"
42# - d9e9cb8ce9bc hx280enc_vc8000e: fix misplaced #endif 42# - 1918c2eb8b07f Revert "dmaengine: fsl-edma: fix DMA channel leak in eDMAv4"
43# - 3f1f2ea72955 mxc: gpu-viv: change _QuerySignal() return type to gceSTATUS 43# - 42289407ee38f Revert "dmaengine: fsl-edma: Add judgment on enabling round robin arbitration"
44# - b73c6797ee42 ARM: imx_v7_defconfig: Remove KERNEL_LZO config 44# - 952f79923f055 Revert "dmaengine: fsl-edma: Do not suspend and resume the masked dma channel when the system is sleeping"
45# - ec33c7fc43be touchscreen: Kconfig: add I2C dependency for CT36X
46# - 6c41233a2cfb pwm: pwm-adp5585: fix get_state callback prototype
47# - 9c7540ecb891 pwm: pwm-rpmsg-imx: fix get_state callback prototype
48# 45#
49# NOTE to upgraders: 46# NOTE to upgraders:
50# This recipe should NOT collect individual patches, they should be applied to 47# This recipe should NOT collect individual patches, they should be applied to
@@ -56,14 +53,14 @@ require linux-imx.inc
56 53
57KBRANCH = "6.6-1.0.x-imx" 54KBRANCH = "6.6-1.0.x-imx"
58SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 55SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
59SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a" 56SRCREV = "776652a165f5bbf30c68a5f6213d75b02e8df11c"
60 57
61# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 58# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
62# required by kernel-yocto.bbclass. 59# required by kernel-yocto.bbclass.
63# 60#
64# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 61# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
65# should be updated once patchlevel is merged. 62# should be updated once patchlevel is merged.
66LINUX_VERSION = "6.6.3" 63LINUX_VERSION = "6.6.28"
67 64
68KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 65KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
69KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 66KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
diff --git a/recipes-kernel/linux/linux-fslc_6.6.bb b/recipes-kernel/linux/linux-fslc_6.6.bb
index e0e68c0b..9132435e 100644
--- a/recipes-kernel/linux/linux-fslc_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc_6.6.bb
@@ -19,10 +19,10 @@ SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=
19# 19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6.26" 22LINUX_VERSION = "6.6.28"
23 23
24KBRANCH = "6.6.x+fslc" 24KBRANCH = "6.6.x+fslc"
25SRCREV = "829705b49b55e0ea4dbb12ed23996a12d01898bf" 25SRCREV = "3beb6fac2c3bda9015892dae8556c5559f2ee234"
26 26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"