summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-06-06 11:44:20 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-06 11:24:42 -0300
commit2ae871f021de04fb3aed22fbd7f76c1d6c6c2872 (patch)
tree91c7e0d3dd6e9f1eb358e784f03198947cc0b421
parent791e20bcd481e221da9cbe1f8df84a05174c4d27 (diff)
downloadmeta-freescale-2ae871f021de04fb3aed22fbd7f76c1d6c6c2872.tar.gz
gstreamer1.0-plugins-good: Use i.MX fork of GST for customizations
Create the new gstreamer recipe with i.mx specific version. Switch to use i.MX fork of GST. Merge inc/bb. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> (cherry picked from commit ab7eda199bd3dbe4c7f14fda1421514723620cda)
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.12.imx.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.12.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.12.imx.bb
new file mode 100644
index 00000000..eef21a02
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.12.imx.bb
@@ -0,0 +1,69 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
6 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7
8GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https"
9SRCBRANCH = "imx-1.12.x"
10
11SRC_URI = " \
12 ${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} \
13"
14SRCREV = "b2c850f295a0fe49310fb60784ac6af4a29bceae"
15
16EXTRA_AUTORECONF = ""
17
18S = "${WORKDIR}/git"
19
20DEPENDS += "gstreamer1.0-plugins-base libcap zlib bzip2"
21
22inherit gettext
23
24PACKAGECONFIG ??= " \
25 ${GSTREAMER_ORC} \
26 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
27 cairo flac gdk-pixbuf gudev jpeg libpng soup speex taglib v4l2 \
28"
29
30X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
31
32PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
33PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
34PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
35PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
36PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
37PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
38PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
39PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
40PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
41PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
42PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
43PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
44PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
45PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
46PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
47PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
48PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
49
50EXTRA_OECONF += " \
51 --enable-bz2 \
52 --enable-oss \
53 --enable-zlib \
54 --disable-aalib \
55 --disable-aalibtest \
56 --disable-directsound \
57 --disable-libcaca \
58 --disable-libdv \
59 --disable-oss4 \
60 --disable-osx_audio \
61 --disable-osx_video \
62 --disable-shout2 \
63 --disable-sunaudio \
64 --disable-waveform \
65"
66
67FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
68
69COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"