diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-06-30 15:28:04 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-08-12 11:41:02 -0300 |
commit | 74b810c4d5aabc6ef2d2bbd2b82dc1f6e283a434 (patch) | |
tree | c551db6cac52892e30de1363125b3e01336c1d31 | |
parent | cfafc51d74e7af329098cb5f721c9951ec5ce997 (diff) | |
download | meta-freescale-74b810c4d5aabc6ef2d2bbd2b82dc1f6e283a434.tar.gz |
linux-qoriq: merge .inc and .bb file
No code change.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r-- | recipes-kernel/linux/linux-qoriq.inc | 56 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_3.12.bb | 58 |
2 files changed, 56 insertions, 58 deletions
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc deleted file mode 100644 index a01798e1..00000000 --- a/recipes-kernel/linux/linux-qoriq.inc +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | inherit kernel kernel-arch qoriq_build_64bit_kernel | ||
2 | inherit fsl-kernel-localversion | ||
3 | require recipes-kernel/linux/linux-dtb.inc | ||
4 | |||
5 | DESCRIPTION = "Linux kernel for Freescale platforms" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | DEPENDS_append = " libgcc" | ||
12 | # not put uImage into /boot of rootfs, install kernel-image if needed | ||
13 | RDEPENDS_kernel-base = "" | ||
14 | |||
15 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
16 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
17 | |||
18 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
19 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
20 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
21 | |||
22 | SCMVERSION ?= "y" | ||
23 | LOCALVERSION = "" | ||
24 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
25 | |||
26 | do_configure_prepend() { | ||
27 | # copy desired defconfig so we pick it up for the real kernel_do_configure | ||
28 | cp ${KERNEL_DEFCONFIG} .config | ||
29 | # add config fragments | ||
30 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
31 | if [ -f "${deltacfg}" ]; then | ||
32 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
33 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
34 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
35 | elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then | ||
36 | ${S}/scripts/kconfig/merge_config.sh -m .config \ | ||
37 | ${S}/arch/powerpc/configs/${deltacfg} | ||
38 | fi | ||
39 | done | ||
40 | cp .config ${WORKDIR}/defconfig | ||
41 | } | ||
42 | |||
43 | do_install_append_qoriq-arm() { | ||
44 | install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} | ||
45 | } | ||
46 | |||
47 | do_deploy_append_qoriq-arm() { | ||
48 | install -m 0644 arch/${ARCH}/boot/zImage ${DEPLOYDIR}/${ZIMAGE_BASE_NAME}.bin | ||
49 | ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage-${MACHINE}.bin | ||
50 | ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage | ||
51 | } | ||
52 | |||
53 | FILES_kernel-image += "/boot/zImage*" | ||
54 | |||
55 | # make everything compatible for the time being | ||
56 | COMPATIBLE_MACHINE = "(qoriq)" | ||
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb index 37e088e7..5d892556 100644 --- a/recipes-kernel/linux/linux-qoriq_3.12.bb +++ b/recipes-kernel/linux/linux-qoriq_3.12.bb | |||
@@ -1,4 +1,10 @@ | |||
1 | require recipes-kernel/linux/linux-qoriq.inc | 1 | inherit kernel kernel-arch qoriq_build_64bit_kernel |
2 | inherit fsl-kernel-localversion | ||
3 | require recipes-kernel/linux/linux-dtb.inc | ||
4 | |||
5 | DESCRIPTION = "Linux kernel for Freescale platforms" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
2 | 8 | ||
3 | SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \ | 9 | SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \ |
4 | file://modify-defconfig-t1040-nr-cpus.patch \ | 10 | file://modify-defconfig-t1040-nr-cpus.patch \ |
@@ -10,5 +16,53 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v1.9.x \ | |||
10 | file://fix-the-compile-issue-under-gcc6.patch \ | 16 | file://fix-the-compile-issue-under-gcc6.patch \ |
11 | file://module-remove-MODULE_GENERIC_TABLE.patch \ | 17 | file://module-remove-MODULE_GENERIC_TABLE.patch \ |
12 | " | 18 | " |
13 | |||
14 | SRCREV = "43cecda943a6c40a833b588801b0929e8bd48813" | 19 | SRCREV = "43cecda943a6c40a833b588801b0929e8bd48813" |
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | DEPENDS_append = " libgcc" | ||
24 | # not put uImage into /boot of rootfs, install kernel-image if needed | ||
25 | RDEPENDS_kernel-base = "" | ||
26 | |||
27 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
28 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
29 | |||
30 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
31 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
32 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
33 | |||
34 | SCMVERSION ?= "y" | ||
35 | LOCALVERSION = "" | ||
36 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
37 | |||
38 | do_configure_prepend() { | ||
39 | # copy desired defconfig so we pick it up for the real kernel_do_configure | ||
40 | cp ${KERNEL_DEFCONFIG} .config | ||
41 | # add config fragments | ||
42 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
43 | if [ -f "${deltacfg}" ]; then | ||
44 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
45 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
46 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
47 | elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then | ||
48 | ${S}/scripts/kconfig/merge_config.sh -m .config \ | ||
49 | ${S}/arch/powerpc/configs/${deltacfg} | ||
50 | fi | ||
51 | done | ||
52 | cp .config ${WORKDIR}/defconfig | ||
53 | } | ||
54 | |||
55 | do_install_append_qoriq-arm() { | ||
56 | install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} | ||
57 | } | ||
58 | |||
59 | do_deploy_append_qoriq-arm() { | ||
60 | install -m 0644 arch/${ARCH}/boot/zImage ${DEPLOYDIR}/${ZIMAGE_BASE_NAME}.bin | ||
61 | ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage-${MACHINE}.bin | ||
62 | ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage | ||
63 | } | ||
64 | |||
65 | FILES_kernel-image += "/boot/zImage*" | ||
66 | |||
67 | # make everything compatible for the time being | ||
68 | COMPATIBLE_MACHINE = "(qoriq)" | ||