summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-02-07 15:27:38 -0300
committerGitHub <noreply@github.com>2024-02-07 15:27:38 -0300
commit2006f8a4cae62687d98d6457ebdf7838756cd291 (patch)
treef6775df8cfbeea2428a1fb3aae6da643933ad2b2
parent480dbf1cbd725a694187708798be7b17568216e7 (diff)
parentfb86e9b882bf4fd715a4e4b14058a61c9f2469ed (diff)
downloadmeta-freescale-2006f8a4cae62687d98d6457ebdf7838756cd291.tar.gz
Merge pull request #1746 from angolini/fix-jailhouse-build-error
jailhouse-imx: Avoid the build error when using -mcpu and -march
-rw-r--r--recipes-extended/jailhouse/files/arm-arm64-Makefile-Remove-march-option-from-Makefile.patch40
-rw-r--r--recipes-extended/jailhouse/jailhouse-imx_git.bb4
2 files changed, 43 insertions, 1 deletions
diff --git a/recipes-extended/jailhouse/files/arm-arm64-Makefile-Remove-march-option-from-Makefile.patch b/recipes-extended/jailhouse/files/arm-arm64-Makefile-Remove-march-option-from-Makefile.patch
new file mode 100644
index 00000000..442d2831
--- /dev/null
+++ b/recipes-extended/jailhouse/files/arm-arm64-Makefile-Remove-march-option-from-Makefile.patch
@@ -0,0 +1,40 @@
1From 7117c1fe979053e4b1071968b444c03fbffe55bb Mon Sep 17 00:00:00 2001
2From: Daiane Angolini <daiane.angolini@foundries.io>
3Date: Tue, 6 Feb 2024 18:01:07 -0300
4Subject: [PATCH] arm:arm64: Makefile: Remove -march option from Makefile
5
6It let the recipe to decide which are the compilation flags to be used.
7
8It acomodates to [1].
9
10[1] https://git.yoctoproject.org/poky/commit/?id=04eac1f2b67eac5f892a9e0f8fcfe54849923af5
11
12Upstream-Status: Inappropriate [See above]
13
14Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
15---
16 hypervisor/arch/arm/Makefile | 2 --
17 hypervisor/arch/arm64/Makefile | 1 -
18 2 files changed, 3 deletions(-)
19
20diff --git a/hypervisor/arch/arm/Makefile b/hypervisor/arch/arm/Makefile
21index a54370fc..cddb6cd3 100644
22--- a/hypervisor/arch/arm/Makefile
23+++ b/hypervisor/arch/arm/Makefile
24@@ -12,5 +12,3 @@
25
26 LINUXINCLUDE += -I$(src)/arch/arm-common/include
27
28-KBUILD_CFLAGS += -marm -march=armv7ve -msoft-float
29-KBUILD_AFLAGS += -march=armv7ve -msoft-float
30diff --git a/hypervisor/arch/arm64/Makefile b/hypervisor/arch/arm64/Makefile
31index 0718994d..5d7a80c6 100644
32--- a/hypervisor/arch/arm64/Makefile
33+++ b/hypervisor/arch/arm64/Makefile
34@@ -12,4 +12,3 @@
35
36 LINUXINCLUDE += -I$(src)/arch/arm-common/include
37
38-KBUILD_CFLAGS += -march=armv8-a+nofp
39--
402.34.1
diff --git a/recipes-extended/jailhouse/jailhouse-imx_git.bb b/recipes-extended/jailhouse/jailhouse-imx_git.bb
index 9c03436c..21a5c93f 100644
--- a/recipes-extended/jailhouse/jailhouse-imx_git.bb
+++ b/recipes-extended/jailhouse/jailhouse-imx_git.bb
@@ -20,7 +20,9 @@ SRCBRANCH = "lf-6.1.36_2.1.0"
20SRCREV = "d3484c68313c2c837eb213ca1aa373e491fbc55f" 20SRCREV = "d3484c68313c2c837eb213ca1aa373e491fbc55f"
21 21
22IMX_JAILHOUSE_SRC ?= "git://github.com/nxp-imx/imx-jailhouse.git;protocol=https" 22IMX_JAILHOUSE_SRC ?= "git://github.com/nxp-imx/imx-jailhouse.git;protocol=https"
23SRC_URI = "${IMX_JAILHOUSE_SRC};branch=${SRCBRANCH}" 23SRC_URI = "${IMX_JAILHOUSE_SRC};branch=${SRCBRANCH} \
24 file://arm-arm64-Makefile-Remove-march-option-from-Makefile.patch \
25 "
24 26
25DEPENDS = " \ 27DEPENDS = " \
26 make-native \ 28 make-native \