summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-04-24 08:28:03 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2023-04-24 11:37:34 -0300
commit2c59b72561134efd8e2adb3e7018d657662d48ad (patch)
tree1271971879a518d0eda6ed4bc51df345fbfe8e12
parent7881147639f28524faad79150fc1b76506cb2391 (diff)
downloadmeta-freescale-2c59b72561134efd8e2adb3e7018d657662d48ad.tar.gz
linux-fslc: remove linux-fslc.inc
The .inc file is pointless as it is dead simple and splitting it just adds complexity, so we can remove it. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-fslc.inc10
-rw-r--r--recipes-kernel/linux/linux-fslc_6.1.bb9
-rw-r--r--recipes-kernel/linux/linux-imx.inc2
-rw-r--r--recipes-kernel/linux/linux-imx_6.1.bb3
4 files changed, 8 insertions, 16 deletions
diff --git a/recipes-kernel/linux/linux-fslc.inc b/recipes-kernel/linux/linux-fslc.inc
deleted file mode 100644
index f081dd7c..00000000
--- a/recipes-kernel/linux/linux-fslc.inc
+++ /dev/null
@@ -1,10 +0,0 @@
1# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require recipes-kernel/linux/linux-imx.inc
5
6DEPENDS += "bc-native"
7
8SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https \
9 file://defconfig"
10LOCALVERSION = "-fslc"
diff --git a/recipes-kernel/linux/linux-fslc_6.1.bb b/recipes-kernel/linux/linux-fslc_6.1.bb
index 9f2ae131..879c9e13 100644
--- a/recipes-kernel/linux/linux-fslc_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc_6.1.bb
@@ -10,9 +10,12 @@ provide support for some backported features and fixes, or because it was applie
10and takes some time to become part of a stable version, or because it is not applicable for \ 10and takes some time to become part of a stable version, or because it is not applicable for \
11upstreaming." 11upstreaming."
12 12
13include linux-fslc.inc 13DEPENDS += "bc-native"
14 14
15LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 15require linux-imx.inc
16
17SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https \
18 file://defconfig"
16 19
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 20# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass. 21# required by kernel-yocto.bbclass.
@@ -24,4 +27,6 @@ LINUX_VERSION = "6.1.24"
24KBRANCH = "6.1.x+fslc" 27KBRANCH = "6.1.x+fslc"
25SRCREV = "4c5917cbbb13c618abe50bb85048b784bd1b1095" 28SRCREV = "4c5917cbbb13c618abe50bb85048b784bd1b1095"
26 29
30LOCALVERSION = "-fslc"
31
27COMPATIBLE_MACHINE = "(imx-generic-bsp)" 32COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-kernel/linux/linux-imx.inc b/recipes-kernel/linux/linux-imx.inc
index 1a37bf20..0150a3f8 100644
--- a/recipes-kernel/linux/linux-imx.inc
+++ b/recipes-kernel/linux/linux-imx.inc
@@ -2,7 +2,7 @@
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4LICENSE = "GPL-2.0-only" 4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 5LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
6 6
7inherit kernel-yocto kernel fsl-kernel-localversion fsl-vivante-kernel-driver-handler 7inherit kernel-yocto kernel fsl-kernel-localversion fsl-vivante-kernel-driver-handler
8 8
diff --git a/recipes-kernel/linux/linux-imx_6.1.bb b/recipes-kernel/linux/linux-imx_6.1.bb
index ca298c4c..f979c146 100644
--- a/recipes-kernel/linux/linux-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-imx_6.1.bb
@@ -12,9 +12,6 @@ i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU
12 12
13require recipes-kernel/linux/linux-imx.inc 13require recipes-kernel/linux/linux-imx.inc
14 14
15LICENSE = "GPL-2.0-only"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18DEPENDS += "lzop-native bc-native" 15DEPENDS += "lzop-native bc-native"
19 16
20# UPGRADE NOTE: 17# UPGRADE NOTE: