summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-04-30 22:51:13 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2023-04-30 23:04:07 -0300
commit9d541fb9644cf4e7b1803096fa1b4896046bfadf (patch)
tree3c9e54ea614b9210f94258016d7883c9e575ce87
parentb211cd09da29c82802a823f42ae0f5005616d2ef (diff)
downloadmeta-freescale-9d541fb9644cf4e7b1803096fa1b4896046bfadf.tar.gz
linux-fslc-imx: remove SoC-specific defconfig to use in-tree defconfig
Fixes: cb4b1f2d ("linux-fslc: remove SoC-specific defconfig to use in-tree defconfig") Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.1.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.1.bb b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
index 8e8b5424..c52b947a 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
@@ -45,12 +45,12 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
45# information should be properly filled in above. 45# information should be properly filled in above.
46############################################################################### 46###############################################################################
47 47
48include linux-fslc.inc 48require linux-imx.inc
49 49
50LICENSE = "GPL-2.0-only" 50DEPENDS += "lzop-native bc-native"
51LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
52 51
53KBRANCH = "6.1-1.0.x-imx" 52KBRANCH = "6.1-1.0.x-imx"
53SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
54SRCREV = "897d73a656fe33d0c4549c5de1d07797f99d6871" 54SRCREV = "897d73a656fe33d0c4549c5de1d07797f99d6871"
55 55
56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
@@ -60,8 +60,13 @@ SRCREV = "897d73a656fe33d0c4549c5de1d07797f99d6871"
60# should be updated once patchlevel is merged. 60# should be updated once patchlevel is merged.
61LINUX_VERSION = "6.1.24" 61LINUX_VERSION = "6.1.24"
62 62
63KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
64KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
65KBUILD_DEFCONFIG:mx8-generic-bsp = "imx_v8_defconfig"
66KBUILD_DEFCONFIG:mx9-generic-bsp = "imx_v8_defconfig"
67
63# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 68# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
64LOCALVERSION = "-6.1.24-1.0.0" 69LOCALVERSION = "-lf-6.1.y"
65 70
66DEFAULT_PREFERENCE = "1" 71DEFAULT_PREFERENCE = "1"
67 72