diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-11 10:52:47 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-11 13:12:29 -0500 |
commit | 5c9e98440a5b84711f0cc5ae340e0ab1de8de123 (patch) | |
tree | 3ea1cb0e9cb2d16dbefb9cb5b21e15d63832c583 | |
parent | 015caea5c777384b44dda89e8c76dadaecc84ddc (diff) | |
download | meta-freescale-5c9e98440a5b84711f0cc5ae340e0ab1de8de123.tar.gz |
imx-g2d-samples: Upgrade 1.0.0 -> 2.0.0
This version of samples supports DPU-based G2D, using G2D API 2.0.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb | 25 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb | 32 |
2 files changed, 32 insertions, 25 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb deleted file mode 100644 index 984c10fc..00000000 --- a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "i.MX G2D Samples" | ||
2 | DESCRIPTION = "Set of sample applications for i.MX G2D" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91" | ||
5 | |||
6 | # This package is currently only for GPU-based G2D. Support for DPU-based G2d is coming. | ||
7 | DEPENDS = "imx-gpu-g2d" | ||
8 | |||
9 | GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https" | ||
10 | SRCBRANCH ?= "imx_1.0" | ||
11 | SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" | ||
12 | SRCREV = "daf64d010666ef2458566573c074e238993f228c" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | do_configure[noexec] = "1" | ||
17 | |||
18 | do_install() { | ||
19 | oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix} | ||
20 | } | ||
21 | |||
22 | FILES:${PN} += "/opt" | ||
23 | |||
24 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
25 | |||
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb new file mode 100644 index 00000000..9832aac2 --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "i.MX G2D Samples" | ||
2 | DESCRIPTION = "Set of sample applications for i.MX G2D" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91" | ||
5 | |||
6 | DEPENDS = "virtual/libg2d" | ||
7 | |||
8 | GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https" | ||
9 | SRCBRANCH ?= "imx_2.0" | ||
10 | SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" | ||
11 | SRCREV = "267af142881d350218c2c2cead8f304a28bbee07" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit pkgconfig | ||
16 | |||
17 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}" | ||
18 | |||
19 | PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols" | ||
20 | |||
21 | EXTRA_OEMAKE += " \ | ||
22 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ | ||
23 | ${PACKAGECONFIG_CONFARGS} \ | ||
24 | " | ||
25 | |||
26 | do_install() { | ||
27 | oe_runmake install DESTDIR=${D} | ||
28 | } | ||
29 | |||
30 | FILES:${PN} += "/opt" | ||
31 | |||
32 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||