diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-01-12 22:46:10 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-02-01 11:24:43 -0300 |
commit | e8fb1c9fed1981494134e945bf7978113583dba6 (patch) | |
tree | 1d246ec4407e6ad7a3e1ff3a0969b368efc1bd76 | |
parent | 5bef551cd1a1711cbe56b769576577b460ef3797 (diff) | |
download | meta-freescale-e8fb1c9fed1981494134e945bf7978113583dba6.tar.gz |
imx-test: upgrade to release 5.4.70_2.3.0
Upgrade recipe to match with release 5.4.70_2.3.0 from NXP.
Drop patch from the layer that is applied upstream, it is covered by the
commit (35881dd "MLK-24751 pxp_test: fix build break with GCC 9.2")
Add new package config option to include SW PDM.
Following commits are included in this update:
----
90fd716 MLK-25007: mxc_audio_monitor: use double type to improve the precision
9e3378e MLK-24989: mxc_audio_monitor: Add support for 8MP
f98b5a8 MLK-24896 mxc_v4l2_vpu_test: integrate VSI unit-test parser
838ea7f MLK-24829:mxc_v4l2_vpu_test: encoder: fix crop setting doesn't take effect
8939e71 MLK-24797: mx8_v4l2_cap_drm.c: fix camera preview not working when run six sensors
af1091d MLK-24692: camera: mx8_v4l2_cap_drm.c support sixteen camera channels
35881dd MLK-24751 pxp_test: fix build break with GCC 9.2
709656b MLK-24736 mxc_v4l2_vpu_test: add parser for JPEG format
7169666 MLK-24533:mxc_v4l2_vpu_test: encoder: align the max buffer count to the v4l2 max buffer count
2ae964b MLK-24499: [8QM_MEK/8QXP_MEK]mxc:vpu_windsor: set low latency mode through set bframe
5ea9607 set hevc profile and level
527092b MLK-24466-2 mxc_v4l2_vpu_test: encoder: refine parser
----
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r-- | recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch | 32 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 6 |
2 files changed, 3 insertions, 35 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch deleted file mode 100644 index 1fe997d7..00000000 --- a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 97a55fe4b1e02b9a4992517234a8b24f8f9f0009 Mon Sep 17 00:00:00 2001 | ||
2 | From: "i.MX Yocto Project Build" <imx.build@nxp.com> | ||
3 | Date: Mon, 27 Jan 2020 13:43:47 -0600 | ||
4 | Subject: [PATCH] pxp test: Fix format-security error | ||
5 | |||
6 | | pxp_lib_test/pxp_test.c: In function 'main': | ||
7 | | pxp_lib_test/pxp_test.c:541:2: error: format not a string literal and no format arguments [-Werror=format-security] | ||
8 | | 541 | printf(usage); | ||
9 | | | ^~~~~~ | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | ||
14 | --- | ||
15 | test/pxp_lib_test/pxp_test.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/test/pxp_lib_test/pxp_test.c b/test/pxp_lib_test/pxp_test.c | ||
19 | index 107198f..72c984d 100644 | ||
20 | --- a/test/pxp_lib_test/pxp_test.c | ||
21 | +++ b/test/pxp_lib_test/pxp_test.c | ||
22 | @@ -538,6 +538,6 @@ int main(int argc, char *argv[]) | ||
23 | |||
24 | return 0; | ||
25 | usage: | ||
26 | - printf(usage); | ||
27 | + printf("%s", usage); | ||
28 | return -1; | ||
29 | } | ||
30 | -- | ||
31 | 2.17.1 | ||
32 | |||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index b9c12e18..da488bd3 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -16,13 +16,12 @@ DEPENDS_append_imxvpu = " virtual/imxvpu" | |||
16 | PE = "1" | 16 | PE = "1" |
17 | PV = "7.0+${SRCPV}" | 17 | PV = "7.0+${SRCPV}" |
18 | 18 | ||
19 | SRCBRANCH = "imx_5.4.47_2.2.0" | 19 | SRCBRANCH = "imx_5.4.70_2.3.0" |
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | 21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ |
22 | file://0001-pxp-test-Fix-format-security-error.patch \ | ||
23 | file://memtool_profile \ | 22 | file://memtool_profile \ |
24 | " | 23 | " |
25 | SRCREV = "31623a4972bf6f2f4239b4667aeb33baba07a3c8" | 24 | SRCREV = "90fd7168fe5f15de9b2b1992a719024fc73a185a" |
26 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
27 | 26 | ||
28 | inherit module-base use-imx-headers | 27 | inherit module-base use-imx-headers |
@@ -48,6 +47,7 @@ PACKAGECONFIG_append_imxvpu = " vpu" | |||
48 | 47 | ||
49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | 48 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" |
50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" | 49 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" |
50 | PACKAGECONFIG[swpdm] = "HAS_IMX_SW_PDM=true,HAS_IMX_SW_PDM=false,imx-sw-pdm" | ||
51 | 51 | ||
52 | do_compile() { | 52 | do_compile() { |
53 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 53 | CFLAGS="${TOOLCHAIN_OPTIONS}" |