summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2017-03-17 15:51:08 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-03-17 17:04:04 -0300
commit8e342b5286f332b4df4fd0c78cde88fcbab29f82 (patch)
tree7ecff62e879c5d688f60ff0d485bf529a4ca5a25
parentcb715502aa7673d558f8e78e2d2d81f28a37ace6 (diff)
downloadmeta-freescale-8e342b5286f332b4df4fd0c78cde88fcbab29f82.tar.gz
ls2-rcw: update to 83a7a66
* add support for ls1012a. * strip possible '-32b', '-64b' and '-be' to match folder name. New commits: 83a7a66 ls1088a: Remove ls1088 directory 585f03e ls208xa: Make folders and name consistent 6a7a0e5 ls2088a: Delete ls2088a rcws as it is not part of SDK f358729 ls1012a: Make folders and name consistent 5b5695f ls1012a: Add support of RCW for FRDM, RDB and QDS boards Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/rcw/ls2-rcw_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/rcw/ls2-rcw_git.bb b/recipes-bsp/rcw/ls2-rcw_git.bb
index 8a0c130f..fafd9141 100644
--- a/recipes-bsp/rcw/ls2-rcw_git.bb
+++ b/recipes-bsp/rcw/ls2-rcw_git.bb
@@ -3,27 +3,29 @@ DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the
3LICENSE = "Freescale-Binary-EULA" 3LICENSE = "Freescale-Binary-EULA"
4LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=8835a59e50213e1b21243dd00c933e47" 4LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=8835a59e50213e1b21243dd00c933e47"
5 5
6inherit deploy 6inherit deploy siteinfo
7 7
8INHIBIT_DEFAULT_DEPS = "1" 8INHIBIT_DEFAULT_DEPS = "1"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;nobranch=1" 11SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;nobranch=1"
12SRCREV = "8a050e0779a9d03ea488d01cc1a31d1e2b1efdba" 12SRCREV = "83a7a661404b760874759073c9f14c8c2c8a9af3"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
17
16do_install () { 18do_install () {
17 install -d ${D}/boot/rcw 19 install -d ${D}/boot/rcw
18 cp -r ${S}/ls2080a/RDB/* ${D}/boot/rcw 20 cp -a ${S}/${M} ${D}/boot/rcw/
19} 21}
20 22
21do_deploy () { 23do_deploy () {
22 install -d ${DEPLOYDIR}/rcw 24 install -d ${DEPLOYDIR}/rcw
23 cp -r ${S}/ls2080a/RDB/* ${DEPLOYDIR}/rcw 25 cp -a ${S}/${M} ${DEPLOYDIR}/rcw/
24} 26}
25addtask deploy before do_build after do_install 27addtask deploy before do_build after do_install
26 28
27PACKAGES += "${PN}-image" 29PACKAGES += "${PN}-image"
28FILES_${PN}-image += "/boot" 30FILES_${PN}-image += "/boot"
29COMPATIBLE_MACHINE = "(ls2080ardb)" 31COMPATIBLE_MACHINE = "(ls1012a|ls2080a)"