summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-04-19 16:52:36 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-02 17:54:58 -0300
commit6f5f87a425a4e54e68321d0910b15eaf32c898d3 (patch)
treef2f4fe619baff68c4908d96594525006fe454742
parent1e48f66e0d7d19c9aee49787c7613539603498af (diff)
downloadmeta-freescale-6f5f87a425a4e54e68321d0910b15eaf32c898d3.tar.gz
skmm-ep:update to de6816c
New commits: de6816c Add back the implicit Makefile rules Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-extended/skmm-ep/skmm-ep/skmm-ep-fix-the-inline-function-definition-with-gcc-.patch67
-rw-r--r--recipes-extended/skmm-ep/skmm-ep/skmm-ep-remove-duplicated-pa_to_va-and-va_to_pa.patch40
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb4
3 files changed, 1 insertions, 110 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep/skmm-ep-fix-the-inline-function-definition-with-gcc-.patch b/recipes-extended/skmm-ep/skmm-ep/skmm-ep-fix-the-inline-function-definition-with-gcc-.patch
deleted file mode 100644
index 7acac8c7..00000000
--- a/recipes-extended/skmm-ep/skmm-ep/skmm-ep-fix-the-inline-function-definition-with-gcc-.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1From 3293321112174ff3247c0ba5c8b9ba9349e0e623 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Mon, 21 Sep 2015 20:38:52 +0800
4Subject: [PATCH] skmm-ep: fix the inline function definition with gcc 5.x
5
6There are different semantics for inline functions for gcc-5.x compared to
7previous gcc. Fix the following build error.
8| skmm.c:(.text.startup+0xfc): undefined reference to `va_to_pa'
9| skmm.c:(.text.startup+0x10c): undefined reference to `va_to_pa'
10
11Upstream-Status: Pending
12
13Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
14---
15 apps/skmm/include/skmm_sram.h | 13 +++++++++++--
16 apps/skmm/lib/skmm_ddr.c | 10 ----------
17 2 files changed, 11 insertions(+), 12 deletions(-)
18
19diff --git a/apps/skmm/include/skmm_sram.h b/apps/skmm/include/skmm_sram.h
20index 4c96874..6208761 100644
21--- a/apps/skmm/include/skmm_sram.h
22+++ b/apps/skmm/include/skmm_sram.h
23@@ -33,9 +33,18 @@
24 #define __SKMM_SRAM_H__
25
26 #include "common.h"
27+#include <usdpaa/dma_mem.h>
28+
29+static inline va_addr_t pa_to_va(phys_addr_t addr)
30+{
31+ return (va_addr_t)__dma_mem_ptov(addr);
32+}
33+
34+static inline phys_addr_t va_to_pa(va_addr_t addr)
35+{
36+ return (phys_addr_t)__dma_mem_vtop((void *)addr);
37+}
38
39-inline phys_addr_t va_to_pa(va_addr_t addr);
40-inline va_addr_t pa_to_va(phys_addr_t addr);
41 va_addr_t *fsl_mem_init(phys_addr_t l2_sram_addr);
42
43 #endif /* __SKMM_SRAM_H__ */
44diff --git a/apps/skmm/lib/skmm_ddr.c b/apps/skmm/lib/skmm_ddr.c
45index d5a66ce..f1cef89 100644
46--- a/apps/skmm/lib/skmm_ddr.c
47+++ b/apps/skmm/lib/skmm_ddr.c
48@@ -35,16 +35,6 @@
49 #define SKMM_TOTAL_DMA_SIZE (64 * 1024 * 1024)
50 #define SKMM_DMA_MAP_SIZE (1*1024*1024)
51
52-inline va_addr_t pa_to_va(phys_addr_t addr)
53-{
54- return (va_addr_t)__dma_mem_ptov(addr);
55-}
56-
57-inline phys_addr_t va_to_pa(va_addr_t addr)
58-{
59- return (phys_addr_t)__dma_mem_vtop((void *)addr);
60-}
61-
62 va_addr_t *fsl_mem_init(phys_addr_t l2_sram_addr)
63 {
64 /* - map DMA mem */
65--
661.9.2
67
diff --git a/recipes-extended/skmm-ep/skmm-ep/skmm-ep-remove-duplicated-pa_to_va-and-va_to_pa.patch b/recipes-extended/skmm-ep/skmm-ep/skmm-ep-remove-duplicated-pa_to_va-and-va_to_pa.patch
deleted file mode 100644
index afa7e894..00000000
--- a/recipes-extended/skmm-ep/skmm-ep/skmm-ep-remove-duplicated-pa_to_va-and-va_to_pa.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1skmm-ep: remove duplicated definition
2
3Remove the duplicated definition to fix the following build errors:
4| apps/skmm/lib/skmm_sram.c:42:18: error: redefinition of 'pa_to_va'
5| apps/skmm/lib/skmm_sram.c:51:20: error: redefinition of 'va_to_pa'
6
7Upstream-Status: Pending
8
9Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
10
11diff --git a/apps/skmm/lib/skmm_sram.c b/apps/skmm/lib/skmm_sram.c
12index 2d84d93..6ab0421 100644
13--- a/apps/skmm/lib/skmm_sram.c
14+++ b/apps/skmm/lib/skmm_sram.c
15@@ -39,24 +39,6 @@
16 static phys_addr_t sram_phys_addr;
17 static va_addr_t sram_virt_addr;
18
19-inline va_addr_t pa_to_va(phys_addr_t addr)
20-{
21- va_addr_t offset;
22-
23- offset = (va_addr_t)(addr - sram_phys_addr);
24-
25- return sram_virt_addr + offset;
26-}
27-
28-inline phys_addr_t va_to_pa(va_addr_t addr)
29-{
30- phys_addr_t offset;
31-
32- offset = (phys_addr_t)(addr - sram_virt_addr);
33-
34- return sram_phys_addr + offset;
35-}
36-
37 static int setup_law_for_plt_sram(phys_addr_t l2sram, u32 *size)
38 {
39 int fd;
40--
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
index 87489660..94649477 100644
--- a/recipes-extended/skmm-ep/skmm-ep_git.bb
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -9,10 +9,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;branch=sdk-v2.0.x \ 10SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;branch=sdk-v2.0.x \
11 file://add-two-missing-header-files.patch \ 11 file://add-two-missing-header-files.patch \
12 file://skmm-ep-fix-the-inline-function-definition-with-gcc-.patch \
13 file://skmm-ep-remove-duplicated-pa_to_va-and-va_to_pa.patch \
14" 12"
15SRCREV = "fc43230ac3044917c9df12e9e4f6a38a4d9b80aa" 13SRCREV = "de6816c7d66129683bc62229b482ac3cf585d896"
16 14
17S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
18 16