summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-04-14 13:01:48 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-02 17:54:57 -0300
commit6e3cc428cfe8c50f38e37161e52a0e63d1f13367 (patch)
tree2a6de5859d6bb742d91eaf2508c36ec051246eab
parent45d09e3ee11e8856462dd20843aeec45a033a36b (diff)
downloadmeta-freescale-6e3cc428cfe8c50f38e37161e52a0e63d1f13367.tar.gz
pkc-firmware: update to 209e0e6
*include the following changes 209e0e6 - ring affinity: keep jobs and responses in the same ring pair 1cd87fb - remove unused parameter from function signature 688e402 - add new handshake parameters (like old is the new new :) bdd38f2 - fix irq missing issue for all rings b5f6504 - rename structure fields to match their content d0b6e25 - fix column alignment to avoid confusion 66ac4ef - remove not used fields from handshake structures 53716e6 - merge together the functions doing ring pairs initialization ffa6360 - make r_cntrs local to the app_ring structure 61a597f - remove not used allocation of s_c_cntrs_mem a1b8599 - remove not used allocation of cntrs_mem 1246eb8 - make ring indices local to the app_ring structure d01ed6c - remove redundant type casts a12f170 - allocate space for input rings independently instead of in bulk e41fc52 - num_of_rps is not used after initialization e827ac6 - refactoring: merge content of two functions 5dcdc32 - device ip_pool is not used on the host so we remove it 21bc000 - merge content of resource struct into c_mem_layout 4b39488 - remove not used function a276c46 - add U suffix to unsigned constants 6d13be3 - remove not used function 0aaeeab - remove redundant busyloop during handshake fe54ba4 - avoid returns from the middle of the handshake function fda0f8e - clean-up for consistent code indentation c441ffc - move macro definition to the header file e87f3e2 - wrap assembly directive with a macro 2091a40 - refactoring: clean-up code style f9261c3 - value returned by sel_sec_enqueue is ignored so make it void a7b2cf7 - avoid linking printf code by default a9cc62d - remove print_error because it duplicates print_debug 542c9d1 - remove deprecated or not used code 542c9d1 - remove deprecated or not used code b11bbbf - fix precision loss conversion errors 428c51c - remove not used code ecd79e6 - avoid playing with compiler optimizations games 5121ad3 - remove deprecated and not used code 949c908 - raise interrupt on the ring that submitted the jobs 92e7089 - refactoring: merge related code into a single function f131421 - remove no longer used handshake fields 6e3ab80 - simplify calculation of msi address 7e337a9 - rename local variables for clarity e4bef8e - refactoring: extract two functions to simplify code 9dd692d - move handshake state initialization to appropriate function 70f061b - cluster together initialization code e92ede5 - remove not used macros 31636ca - remove duplicated function 7c87c3a - search the ring that received rng descriptors and remove waiting 9d132e3 - remove inconsistently used local variable 4fab968 - remove ignored variable dcbdc8a - start counting SEC engines from 0 as in C29x documentation 2189d7a - remove not-used structure field sec_jr.id 739e1cc - remove not used structure field sec 4bb7e8f - use a dummy allocator to keep track of data addresses 0d960b7 - remove padding fields from handshake structures 6973141 - remove not used structure members dgb_print & err_print f3c1977 - remove not used structure members intr_*_ticks 612371b - rearrange code to merge two #ifdef's a86a0a9 - move definition to the header file ff8ce9d - remove unused function wait_for_timeout 97a0657 - remove unused typedef shadow_indexes_mem_t 5d0e0b0 - remove redundant definitions of standard types 86a6451 - remove unused function irja_signal_caam 8106252 - remove unused function circ_room 086f102 - job ring result has no significance as a signed integer dc8f37d - remove not used members of sec_engine structure 9a6a5c2 - rewrite the initalization code for sec engines list 8ab2b15 - remove priority queues and ignore ring order settings 1b48817 - remove not used struct member order_j_d_index e64f7fc - remove not used struct member resp_j_done_flag 7b20be4 - remove the assumption that ring 0 has any special significance 0d9946b - make explicit that we are using C89/90 standard with GNU extensions cf7cd79 - remove not used padding fields in handshake structure d7adc6e - pad not used handshake fields to prepare for their removal 670c95f - make explicit that we have a single response ring hardcoded to id 0 db84b26 - remove not used structure variable enqcount 07b9fda - remove not used structure pointer cmdrp b253763 - don't send available data through stack 0d19768 - remove macro hiding simple code 0aaba96 - remove commented code 8278186 - remove code supporting P4080 prototypes f88a9bc - remove non-high-perf supporting code 090755e - remove not used structure cmd_tbl_s 4f8184b - remove not used orig_rps structure variable 0a635a9 - remove not used structure variable drv_resp_ring_count 3432b1c - rename structure variable ring_count to num_of_rps 71a3a3d - remove duplicated assignment Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/pkc-firmware/pkc-firmware_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
index bc61d676..f5848ebe 100644
--- a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
+++ b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
@@ -10,8 +10,8 @@ inherit deploy
10 10
11PACKAGE_ARCH = "${MACHINE_ARCH}" 11PACKAGE_ARCH = "${MACHINE_ARCH}"
12 12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v2.0.x" 13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1"
14SRCREV = "f75d281d83e74758f54d85bacfa74b7c07514413" 14SRCREV = "209e0e6babdab43f38db84591307bedfd0bed542"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17