summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-04-19 15:56:36 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-02 17:54:58 -0300
commit447567249094f977464e4848815f46e76a4a8af9 (patch)
tree10f006acfa84b1c06e8a30c289698fda3430f6c2
parentd90fd90c278d7960881a27aac43ff9ca678a5805 (diff)
downloadmeta-freescale-447567249094f977464e4848815f46e76a4a8af9.tar.gz
dce: add recipes
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch27
-rw-r--r--recipes-dpaa2/dce/dce_git.bb19
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch b/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch
new file mode 100644
index 00000000..de8ae0c8
--- /dev/null
+++ b/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch
@@ -0,0 +1,27 @@
1Subject: [PATCH] Makefile:Obey LDFLAGS in Makefile
2
3This avoids a "QA Issue: No GNU_HASH in the elf binary"
4
5Upstream-Status: Pending
6
7Signed-off-by:Chunrong Guo <chunrong.guo@nxp.com>
8
9--- a/Makefileold 2017-04-19 15:32:36.512525035 +0800
10+++ b/Makefile 2017-04-19 15:34:29.560521121 +0800
11@@ -46,13 +46,13 @@
12 all: basic_dce_test basic_dce_perf basic_dce_sanity
13
14 basic_dce_test: tests/basic_dce_test.o libdce.a
15- $(CC) $(CFLAGS) $^ -o $@
16+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
17
18 basic_dce_perf: tests/basic_dce_perf.o libdce.a
19- $(CC) $(CFLAGS) $^ -o $@
20+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
21
22 basic_dce_sanity: tests/basic_dce_sanity.o libdce.a
23- $(CC) $(CFLAGS) $^ -o $@
24+ $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS)
25
26 libdce.a: $(OBJS)
27 $(AR) rcs $@ $(OBJS)
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb
new file mode 100644
index 00000000..fb38636e
--- /dev/null
+++ b/recipes-dpaa2/dce/dce_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Decompression Compression Engine Userspace Utils"
2SECTION = "dpaa2"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3bb80dec5c1b94d99a1422cbfd96192c"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/dce.git;nobranch=1 \
7 file://Makefile-obey-LDFLAGS.patch \
8"
9SRCREV = "c31f81667f5cebb3e5331c50655473301672e4de"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
14
15do_install () {
16 oe_runmake install DESTDIR=${D}
17}
18
19COMPATIBLE_MACHINE = "(ls2080a|ls2088a)"