summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagnagianfranco@yahoo.it>2017-10-04 15:41:05 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-05 15:23:40 -0300
commit1310cba8b82509b5cb40f026e4bc023fc46347de (patch)
treec7d3801fc4ad9967a25e1ff0e81d271a8273d790
parentd0d5e2ccc42f189b1b062d004795b84fdf679d70 (diff)
downloadmeta-freescale-1310cba8b82509b5cb40f026e4bc023fc46347de.tar.gz
imx-uuc: update to new git hash, where the patch is been accepted upstream
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch44
-rw-r--r--recipes-bsp/imx-uuc/imx-uuc_git.bb5
2 files changed, 2 insertions, 47 deletions
diff --git a/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch b/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch
deleted file mode 100644
index 36ce2f06..00000000
--- a/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From bfdf01bfb462b21cf0a8f3e35d160b8ee4cea4ab Mon Sep 17 00:00:00 2001
2From: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com>
3Date: Tue, 3 Oct 2017 08:58:08 +0200
4Subject: [PATCH] Fix missing build flags, leading to yocto QA issues
5
6ERROR: imx-uuc-0.5.1+gitAUTOINC+1de598e7b3-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'imx-uuc/0.5.1+gitAUTOINC+1de598e7b3-r0/packages-split/imx-uuc/usr/bin/uuc'
7No GNU_HASH in the elf binary: 'imx-uuc/0.5.1+gitAUTOINC+1de598e7b3-r0/packages-split/imx-uuc/usr/bin/sdimage' [ldflags]
8
9similar issues have been reported on meta-freescale mail list too and then I'm attaching the Found-by/Signed-off-by flags correspondingly:
10(the patches were against meta-freescale, I'm upstreaming them with some little changes)
11https://lists.yoctoproject.org/pipermail/meta-freescale/2017-April/020355.html
12
13Found-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com>
14Found-by: Joel Esponde <Joel.Esponde@Honeywell.com>
15Signed-off-by: Bas Mevissen <bas.mevissen@emcodev.nl>
16---
17 Makefile | 5 +++--
18 1 file changed, 3 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile b/Makefile
21index 5e2816c..1a8f51f 100644
22--- a/Makefile
23+++ b/Makefile
24@@ -1,14 +1,15 @@
25 CC ?= $(CROSS_COMPILE)gcc
26 BINDIR ?= /usr/bin
27 PROGRAMS = uuc sdimage
28+LIBS ?= -lpthread
29
30 all: $(PROGRAMS)
31
32 uuc: uu.c
33- $(CC) $(CFLAGS) uu.c -o uuc -lpthread
34+ $(CC) $(CFLAGS) $(CPPFLAGS) uu.c -o uuc $(LDFLAGS) $(LIBS)
35
36 sdimage: sdimage.c
37- $(CC) $(CFLAGS) sdimage.c -o sdimage
38+ $(CC) $(CFLAGS) $(CPPFLAGS) sdimage.c -o sdimage $(LDFLAGS)
39
40 install:
41 install -d $(DESTDIR)$(BINDIR)
42--
432.11.0
44
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb
index a019fa17..3c54d268 100644
--- a/recipes-bsp/imx-uuc/imx-uuc_git.bb
+++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb
@@ -10,9 +10,8 @@ inherit autotools-brokensep
10 10
11PV = "0.5.1+git${SRCPV}" 11PV = "0.5.1+git${SRCPV}"
12 12
13SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https \ 13SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https"
14 file://0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch " 14SRCREV = "2ae634281a39c82b6a8ee0fdcfbfbe42183ceb53"
15SRCREV = "1de598e7b36d95596435902106c9a746697b9afc"
16 15
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17