summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2017-05-16 08:15:10 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-22 22:27:03 -0300
commitefa7da9da6c71ec8e5c0da64a274a33fa574b05e (patch)
treeca23cc8bf0e39dc849827033c796ceecd5949eb2
parente492297efb2c472f2cf580b06f54667df1593597 (diff)
downloadmeta-freescale-efa7da9da6c71ec8e5c0da64a274a33fa574b05e.tar.gz
mesa: fix configuration rewrite
to change just the PACKAGECONFIG[x11] setting (without expansion), instead of overwriting EXTRA_OECONF (with expansion). Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 3005fd73..863131d1 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -9,9 +9,8 @@ python () {
9 if "imxgpu2d" not in overrides: 9 if "imxgpu2d" not in overrides:
10 return 10 return
11 11
12 extra_oeconf = d.getVar("EXTRA_OECONF", True) 12 x11flag = d.getVarFlag("PACKAGECONFIG", "x11", False)
13 extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx") 13 d.setVarFlag("PACKAGECONFIG", "x11", x11flag.replace("--enable-glx-tls", "--enable-glx"))
14 d.setVar("EXTRA_OECONF", extra_oeconf)
15} 14}
16 15
17# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 16# FIXME: Dirty hack to allow use of Vivante GPU libGL binary