summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-11 09:57:46 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-22 22:27:03 -0300
commite492297efb2c472f2cf580b06f54667df1593597 (patch)
tree1485c03f89a99863896e67f8f26d151b793aa875
parent435eab8c69441e2cfbc709529bd39ccdd155aaf7 (diff)
downloadmeta-freescale-e492297efb2c472f2cf580b06f54667df1593597.tar.gz
imx-kobs: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch33
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_git.bb2
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch b/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch
new file mode 100644
index 00000000..9c86f074
--- /dev/null
+++ b/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch
@@ -0,0 +1,33 @@
1From c183a648958ab4454247cfd88d01da7730a53d19 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 11 May 2017 00:59:07 -0700
4Subject: [PATCH] Add missing includes as pointed out by musl
5
6These headers are indrectly included when building with
7glibc, this is exposed when compiling with musl systems
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 src/mtd.h | 3 +++
12 1 file changed, 3 insertions(+)
13
14diff --git a/src/mtd.h b/src/mtd.h
15index 6cb0ca2..0eaea48 100644
16--- a/src/mtd.h
17+++ b/src/mtd.h
18@@ -25,9 +25,12 @@
19 #ifndef MTD_H
20 #define MTD_H
21
22+#define _GNU_SOURCE
23+#include <fcntl.h>
24 #include <mtd/mtd-user.h>
25 #include <endian.h>
26 #include <stdint.h>
27+#include <stddef.h>
28
29 #include "BootControlBlocks.h"
30 #include "rom_nand_hamming_code_ecc.h"
31--
322.12.2
33
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb
index aab10f9c..eaea1657 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_git.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb
@@ -10,6 +10,8 @@ PV = "5.5+git${SRCPV}"
10SRCREV = "a2734b93759b4222f9dfa3f8c7645be9d39ea601" 10SRCREV = "a2734b93759b4222f9dfa3f8c7645be9d39ea601"
11 11
12SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https" 12SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https"
13 file://0001-Add-missing-includes-as-pointed-out-by-musl.patch \
14"
13 15
14S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
15 17