summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-13 18:15:50 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-05-20 12:05:49 +0800
commit8dcb3bb6595b8930039d94456f63fbbef490b02a (patch)
tree7a181ef7def08b0d95f958ef2ae9ed23e9190e48
parentf9ad49d43e342e90fdbd5ab6c49cb99ca28ef53c (diff)
downloadmeta-freescale-8dcb3bb6595b8930039d94456f63fbbef490b02a.tar.gz
ipc: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. ipc Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--meta-fsl-ppc/recipes-kernel/ipc/ipc-modules.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/ipc/ipc-modules.inc b/meta-fsl-ppc/recipes-kernel/ipc/ipc-modules.inc
index e403e6bb..79ba7ef1 100644
--- a/meta-fsl-ppc/recipes-kernel/ipc/ipc-modules.inc
+++ b/meta-fsl-ppc/recipes-kernel/ipc/ipc-modules.inc
@@ -9,6 +9,11 @@ inherit module qoriq_build_64bit_kernel
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12do_configure[depends] += "virtual/kernel:do_shared_workdir"
13do_configure_prepend() {
14 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile
15}
16
12do_compile_prepend () { 17do_compile_prepend () {
13 cd ${S}/kernel 18 cd ${S}/kernel
14 case ${MACHINE} in 19 case ${MACHINE} in