summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2017-03-07 01:26:15 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2017-03-09 17:33:58 -0300
commit4c19731b5c5ed63aef365eb173a03ef3ef303fb1 (patch)
tree7729e301a59092bb9f11bb63da0973db913944a0
parentc0942fad3c9d2b024cc6e63e82cff4bef4d03faa (diff)
downloadmeta-freescale-4c19731b5c5ed63aef365eb173a03ef3ef303fb1.tar.gz
xorg-driver: remove the local copies of xorg-driver-*.inc
recipes-graphics/xorg-driver/xorg-driver-common.inc is identical to the copy in openembedded-core. xorg-driver-video.inc lacks the automatic addition of xorg-driver-abi-<ABI> to RDEPENDS. (and constructs DEPENDS differently but with the same effect) xf86-video-fbdev must now provide the full relative path for its include file. fixes: WARNING: xf86-video-imxfb-vivante-3_5.0.11.p8.6-r0 do_package_qa: QA Issue: Package xf86-video-imxfb-vivante contains Xorg driver (vivante_drv.so) but no xorg-abi- dependencies [xorg-driver-abi] and likely but not tested fixes the same warning for xf86-video-fbdev used for PPC devices. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb2
-rw-r--r--recipes-graphics/xorg-driver/xorg-driver-common.inc40
-rw-r--r--recipes-graphics/xorg-driver/xorg-driver-video.inc4
3 files changed, 1 insertions, 45 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb
index 038c421d..996a9c7f 100644
--- a/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb
@@ -1,4 +1,4 @@
1require xorg-driver-video.inc 1require recipes-graphics/xorg-driver/xorg-driver-video.inc
2LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8" 2LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8"
3 3
4DESCRIPTION = "X.Org X server -- fbdev display driver" 4DESCRIPTION = "X.Org X server -- fbdev display driver"
diff --git a/recipes-graphics/xorg-driver/xorg-driver-common.inc b/recipes-graphics/xorg-driver/xorg-driver-common.inc
deleted file mode 100644
index c0f4a15a..00000000
--- a/recipes-graphics/xorg-driver/xorg-driver-common.inc
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "X driver"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/drivers"
4LICENSE = "MIT-X"
5INC_PR = "r15"
6
7DEPENDS = "randrproto virtual/xserver-xf86 xproto"
8
9SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13FILES_${PN} += " ${libdir}/xorg/modules"
14FILES_${PN}-dbg += "${libdir}/xorg/modules/*/.debug"
15
16inherit autotools pkgconfig
17
18TARGET_CPPFLAGS += "-I${STAGING_DIR_HOST}/usr/include/xorg"
19
20# Another sucky behavor from Xorg configure scripts.
21# They use AC_CHECK_FILE to check for DRI headers. Yuck!
22# Of course this will blow up when cross compiling.
23
24do_configure_prepend() {
25 incdir=${layout_includedir}/xorg
26 for f in dri.h sarea.h dristruct.h exa.h damage.h xf86Module.h; do
27 path="$incdir/$f"
28 if [ -f "${STAGING_DIR_HOST}/$path" ]; then
29 p=`echo "$path" | sed 'y%*+%pp%;s%[^_[:alnum:]]%_%g'`
30 eval "export ac_cv_file_$p=yes"
31 fi
32 done
33}
34
35# FIXME: We don't want to include the libtool archives (*.la) from modules
36# directory, as they serve no useful purpose. Upstream should fix Makefile.am
37do_install_append() {
38 find ${D}${libdir}/xorg/modules -regex ".*\.la$" | xargs rm -f --
39}
40
diff --git a/recipes-graphics/xorg-driver/xorg-driver-video.inc b/recipes-graphics/xorg-driver/xorg-driver-video.inc
deleted file mode 100644
index bce8c9a7..00000000
--- a/recipes-graphics/xorg-driver/xorg-driver-video.inc
+++ /dev/null
@@ -1,4 +0,0 @@
1include xorg-driver-common.inc
2
3DEPENDS = "randrproto renderproto videoproto xextproto fontsproto xproto"
4