summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-09 17:32:13 -0700
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-11-02 12:49:48 +0000
commitc1d07e064d42bd5e1c60efb236515073a422b6aa (patch)
treee5e23183c6042316b7ddc20f0dc6f6e0f1972243
parent7625e33cd7fd752ee04c7b9b5ba38b73961979ad (diff)
downloadmeta-freescale-c1d07e064d42bd5e1c60efb236515073a422b6aa.tar.gz
imx-atf: Explicitly demand BFD linker
This component uses BFD linker specific options which may not be available when default ld is not GNU BFD LD Fixes | aarch64-yoe-linux-ld: error: unknown argument '--fix-cortex-a53-835769' Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 79bfb17b47e77af1dffcb7bac843965b15f00a9a)
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b39d954d..5016e730 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -52,7 +52,7 @@ def remove_options_tail (in_string):
52 from itertools import takewhile 52 from itertools import takewhile
53 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 53 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
54 54
55EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"' 55EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}.bfd"'
56 56
57EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 57EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
58 58