summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-10-10 08:59:45 -0300
committerGitHub <noreply@github.com>2023-10-10 08:59:45 -0300
commitad424a73b3f815589fef00e366a33eacab3bfcee (patch)
treeaf7e40b9362d0b888bd28b81c40acca9c22da186
parentf5cc0843233ad0df25aaf801198f67a9c1774a54 (diff)
parenta7c5abfe5d102d46f9139f6374f94ac9287f9c35 (diff)
downloadmeta-freescale-ad424a73b3f815589fef00e366a33eacab3bfcee.tar.gz
Merge pull request #1663 from hiagofranco/add_uuu-bin_to_kirkstone
Add uuu bin to kirkstone
-rw-r--r--recipes-devtools/uuu/uuu-bin_1.4.243.bb35
-rw-r--r--recipes-devtools/uuu/uuu_git.bb4
2 files changed, 37 insertions, 2 deletions
diff --git a/recipes-devtools/uuu/uuu-bin_1.4.243.bb b/recipes-devtools/uuu/uuu-bin_1.4.243.bb
new file mode 100644
index 00000000..4ad823aa
--- /dev/null
+++ b/recipes-devtools/uuu/uuu-bin_1.4.243.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2022-2023 O.S. Systems Software LTDA.
2# Released under the MIT License (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Update Utility - Binaries"
5DESCRIPTION = "Image deploy tool for i.MX chips"
6HOMEPAGE = "https://github.com/nxp-imx/mfgtools"
7
8LICENSE = "BSD-3-Clause & LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
10 file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68"
11
12SRC_URI = " \
13 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu;downloadfilename=uuu-${PV};name=Linux \
14 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu_mac;downloadfilename=uuu-${PV}_mac;name=Mac \
15 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu.exe;downloadfilename=uuu-${PV}.exe;name=Windows \
16"
17
18SRC_URI[Linux.sha256sum] = "dfb2a6dca337ebd59675ea5ce7f1bce6724e3b901bcb455126d4bf9bdfa2e585"
19SRC_URI[Mac.sha256sum] = "399efa4bc7e3eb452fefe89ef5e2e453b516ea716658a963a890c430ad81a471"
20SRC_URI[Windows.sha256sum] = "f3f178e7be161c7dc058dbcd35c8cfa1516981e7c4f915fe0256ae4cda7f101e"
21
22S = "${WORKDIR}"
23
24inherit allarch
25
26do_install() {
27 install -D -m 0755 ${WORKDIR}/uuu-${PV} ${D}${libdir}/uuu/uuu
28 install -D -m 0755 ${WORKDIR}/uuu-${PV}_mac ${D}${libdir}/uuu/uuu_mac
29 install -D -m 0644 ${WORKDIR}/uuu-${PV}.exe ${D}${libdir}/uuu/uuu.exe
30}
31
32# HACK! We are not aiming to run those binaries during the build but copy then for MFGTOOL bundle.
33INSANE_SKIP:${PN} += "arch file-rdeps"
34FILES:${PN} = "${libdir}/uuu"
35SYSROOT_DIRS = "${libdir}/uuu"
diff --git a/recipes-devtools/uuu/uuu_git.bb b/recipes-devtools/uuu/uuu_git.bb
index 6b1ecb1f..e4a23cde 100644
--- a/recipes-devtools/uuu/uuu_git.bb
+++ b/recipes-devtools/uuu/uuu_git.bb
@@ -1,8 +1,8 @@
1SUMMARY = "Universal Update Utility" 1SUMMARY = "Universal Update Utility"
2DESCRIPTION = "Image deploy tool for i.MX chips" 2DESCRIPTION = "Image deploy tool for i.MX chips"
3HOMEPAGE = "https://github.com/NXPmicro/mfgtools" 3HOMEPAGE = "https://github.com/nxp-imx/mfgtools"
4 4
5SRC_URI = "git://github.com/NXPmicro/mfgtools.git;protocol=https;branch=master" 5SRC_URI = "git://github.com/nxp-imx/mfgtools.git;protocol=https;branch=master"
6SRCREV = "ed48c514ee4c1ea4562c875877b180a87474f895" 6SRCREV = "ed48c514ee4c1ea4562c875877b180a87474f895"
7PV = "1.4.243" 7PV = "1.4.243"
8 8