summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-01-17 17:48:45 -0300
committerGitHub <noreply@github.com>2022-01-17 17:48:45 -0300
commit45dd70ae9428f67e3c8c39f3acf112d2cd710eb9 (patch)
tree96e84771aea7e68c0cb92f152248af350cba24db
parentc55bfa50ae7894b279d54a7e33a0227b492032b6 (diff)
parent8ad986b960efedea3af52083c38aaabdb92156e6 (diff)
downloadmeta-freescale-45dd70ae9428f67e3c8c39f3acf112d2cd710eb9.tar.gz
Merge pull request #948 from Freescale/backport-942-to-honister
[Backport honister] Add imx-dsp recipes and enable imx-gst1.0-plugin to support i.MX Audio DSP Codec
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb4
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb21
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb45
3 files changed, 70 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index 9d43a175..b5fb8890 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -49,6 +49,10 @@ PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN
49# Add codec list that the beep plugin run-time depended 49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" 50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " 51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52RDEPENDS:${PN}:append:mx8qm = " imx-dsp"
53RDEPENDS:${PN}:append:mx8qxp = " imx-dsp"
54RDEPENDS:${PN}:append:mx8mp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8ulp = " imx-dsp"
52 56
53# overlaysink rely on G2D, 57# overlaysink rely on G2D,
54# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D 58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
diff --git a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
new file mode 100644
index 00000000..fe653c18
--- /dev/null
+++ b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
@@ -0,0 +1,21 @@
1# Copyright 2018-2021 NXP
2
3DESCRIPTION = "i.MX DSP Codec Wrapper and Lib owned by NXP"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6
7inherit fsl-eula-unpack autotools pkgconfig
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11SRC_URI[md5sum] = "9e1d0e06f4fed47a37cb390e135f453f"
12SRC_URI[sha256sum] = "2703a9dc619a2ac32352d65cfa58f8217e65abcabd33b77b0be02425dc896ae2"
13
14# Fix strip command failed: 'Unable to recognise the format of the input file'
15INHIBIT_PACKAGE_STRIP = "1"
16INHIBIT_SYSROOT_STRIP = "1"
17INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
18INSANE_SKIP:${PN} = "arch dev-so"
19
20FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm"
21COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8mp|mx8ulp)"
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
new file mode 100644
index 00000000..fe650eb1
--- /dev/null
+++ b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
@@ -0,0 +1,45 @@
1# Copyright 2017-2021 NXP
2
3DESCRIPTION = "i.MX DSP Wrapper, Firmware Binary, Codec Libraries"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6
7inherit fsl-eula-unpack autotools pkgconfig
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11SRC_URI[md5sum] = "238d3f0256573ca657228d7090bcb7d3"
12SRC_URI[sha256sum] = "13f67f267d6d33e8be2a6c258a46cde3667258ac86435776cbf1a370de611476"
13
14EXTRA_OECONF += " \
15 -datadir=${base_libdir}/firmware --bindir=/unit_tests \
16 ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', ' ', d)} \
17"
18
19RDEPENDS:${PN} += " imx-dsp-codec-ext"
20
21HIFI4_BIN ?= "hifi4_imx8qmqxp.bin"
22HIFI4_BIN:mx8mp = "hifi4_imx8mp.bin"
23HIFI4_BIN:mx8ulp = "hifi4_imx8ulp.bin"
24
25do_install:append () {
26 # Rename DSP Firmware into hifi4.bin and remove unneeded binary
27 mv ${D}/lib/firmware/imx/dsp/${HIFI4_BIN} ${D}/lib/firmware/imx/dsp/hifi4.bin
28 find ${D}/lib/firmware/imx/dsp -name hifi4_*.bin -exec rm {} \;
29}
30
31FILES:${PN} = "${libdir}/imx-mm/audio-codec/dsp \
32 ${libdir}/imx-mm/audio-codec/wrap \
33 ${base_libdir}/firmware/imx/dsp \
34 /unit_tests \
35"
36
37INSANE_SKIP:${PN} = "already-stripped arch ldflags dev-so"
38
39# Fix strip command failed: 'Unable to recognise the format of the input file'
40INHIBIT_PACKAGE_STRIP = "1"
41INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
42INHIBIT_SYSROOT_STRIP = "1"
43
44PACKAGE_ARCH = "${MACHINE_ARCH}"
45COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8mp|mx8ulp)"