summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2016-04-15 15:02:53 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:06:34 -0300
commiteebfe50236edfca6438168e047d5592fd0320ddd (patch)
treec824f650cdb1c010848bebcfeb94e034657030d5
parent6bd357c1b38555cd7011434a28df66effe30b74e (diff)
downloadmeta-freescale-eebfe50236edfca6438168e047d5592fd0320ddd.tar.gz
imx-kobs: Fix compiler error with Linux kernel headers version >= 4.4
This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must be explicitly included to get uintX_t types. Change-Id: I3a0059a59bf578fdba0cf68370eec0e19fc10835 Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch17
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_5.4.bb4
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
new file mode 100644
index 00000000..2ac73aef
--- /dev/null
+++ b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
@@ -0,0 +1,17 @@
1This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must
2be explicitly included to get uintX_t types.
3
4Upstream-Status: Pending
5
6Index: imx-kobs-5.4/src/BootControlBlocks.h
7===================================================================
8--- imx-kobs-5.4.orig/src/BootControlBlocks.h
9+++ imx-kobs-5.4/src/BootControlBlocks.h
10@@ -54,6 +54,7 @@
11 //! This structure holds the timing for the NAND. This data is used by
12 //! rom_nand_hal_GpmiSetNandTiming to setup the GPMI hardware registers.
13
14+#include <stdint.h>
15 typedef struct _NAND_Timing {
16 uint8_t m_u8DataSetup;
17 uint8_t m_u8DataHold;
diff --git a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
index 54871601..1d33d40b 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
@@ -5,7 +5,9 @@ SECTION = "base"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
7 7
8SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz" 8SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz \
9 file://fix-compile.patch \
10"
9 11
10SRC_URI[md5sum] = "77467d834f858c2ec216841583e5f437" 12SRC_URI[md5sum] = "77467d834f858c2ec216841583e5f437"
11SRC_URI[sha256sum] = "85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf" 13SRC_URI[sha256sum] = "85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf"