diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-06-25 21:11:43 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-05 15:32:27 -0300 |
commit | 74ae306d33971487efbe5faddcaeca670ec7634d (patch) | |
tree | 4e313d68d6af61eaed09da71dc299bc140d95616 | |
parent | 33cfb1800371a5aed74fd99a8cb6c56d118affd4 (diff) | |
download | meta-freescale-74ae306d33971487efbe5faddcaeca670ec7634d.tar.gz |
weston: Remove OpenGL requirement for i.MX 6SL
OpenGL is not required for parts with 2D GPU
but no 3D GPU.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-graphics/wayland/weston_4.0.0.imx.bb | 10 |
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_4.0.0.imx.bb index 5028cc11..d656aa25 100644 --- a/recipes-graphics/wayland/weston_4.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_4.0.0.imx.bb | |||
@@ -19,8 +19,10 @@ S = "${WORKDIR}/git" | |||
19 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" | 19 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" |
20 | 20 | ||
21 | inherit autotools pkgconfig useradd distro_features_check | 21 | inherit autotools pkgconfig useradd distro_features_check |
22 | # depends on virtual/egl | 22 | # Disable OpenGL for parts with GPU support for 2D but not 3D |
23 | REQUIRED_DISTRO_FEATURES = "opengl" | 23 | REQUIRED_DISTRO_FEATURES = "opengl" |
24 | REQUIRED_DISTRO_FEATURES_imxgpu2d = "" | ||
25 | REQUIRED_DISTRO_FEATURES_imxgpu3d = "opengl" | ||
24 | 26 | ||
25 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | 27 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" |
26 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | 28 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" |
@@ -44,7 +46,7 @@ EXTRA_OECONF_append_mx7 = "\ | |||
44 | " | 46 | " |
45 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | 47 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ |
46 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ | 48 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ |
47 | ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \ | 49 | ${@bb.utils.filter('DISTRO_FEATURES', 'opengl pam systemd x11', d)} \ |
48 | clients launch" | 50 | clients launch" |
49 | # drm is not supported on mx6/mx7 | 51 | # drm is not supported on mx6/mx7 |
50 | PACKAGECONFIG_remove_mx6 = "kms" | 52 | PACKAGECONFIG_remove_mx6 = "kms" |
@@ -88,6 +90,8 @@ PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo | |||
88 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" | 90 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" |
89 | # Weston with i.MX G2D renderer | 91 | # Weston with i.MX G2D renderer |
90 | PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d" | 92 | PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d" |
93 | # Weston with OpenGL support | ||
94 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" | ||
91 | 95 | ||
92 | do_install_append() { | 96 | do_install_append() { |
93 | # Weston doesn't need the .la files to load modules, so wipe them | 97 | # Weston doesn't need the .la files to load modules, so wipe them |