diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-16 15:12:25 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-18 13:48:56 -0300 |
commit | 3149d19df834689da11865c819e4c248e736a744 (patch) | |
tree | cc589e1d5aab59dca3b2fef5fa440ad44a7cff4c | |
parent | 5943060c8ea892054f2d995d398e21bcb2237543 (diff) | |
download | meta-freescale-3149d19df834689da11865c819e4c248e736a744.tar.gz |
u-boot-imx-tools: Drop i.MX specific tools
We are building same tools as the original U-Boot thus we should rely on
them.
This is critical as native tools cannot vary between machines as there
are no clear reason to convert this to be a cross tool as we build no
machine specific code.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | conf/machine/include/imx-base.inc | 5 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb | 15 |
2 files changed, 0 insertions, 20 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 14008927..16d48da9 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -67,15 +67,10 @@ UBOOT_SUFFIX ?= "${UBOOT_SUFFIX_pn-${IMX_DEFAULT_BOOTLOADER}}" | |||
67 | # wic based images. | 67 | # wic based images. |
68 | SPL_BINARY ??= "${@get_spl_binary(d)}" | 68 | SPL_BINARY ??= "${@get_spl_binary(d)}" |
69 | 69 | ||
70 | IMX_DEFAULT_UBOOTTOOLS = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-tools', 'u-boot-tools', d)}" | ||
71 | IMX_DEFAULT_MFGTOOL = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-mfgtool', 'u-boot-fslc', d)}" | 70 | IMX_DEFAULT_MFGTOOL = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-mfgtool', 'u-boot-fslc', d)}" |
72 | 71 | ||
73 | PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}" | 72 | PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}" |
74 | PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_MFGTOOL}" | 73 | PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_MFGTOOL}" |
75 | PREFERRED_PROVIDER_u-boot-tools-native ??= "${IMX_DEFAULT_UBOOTTOOLS}-native" | ||
76 | PREFERRED_PROVIDER_nativesdk-u-boot-tools ??= "nativesdk-${IMX_DEFAULT_UBOOTTOOLS}" | ||
77 | PREFERRED_PROVIDER_u-boot-mkimage-native ??= "${IMX_DEFAULT_UBOOTTOOLS}-native" | ||
78 | PREFERRED_PROVIDER_nativesdk-u-boot-mkimage ??= "nativesdk-${IMX_DEFAULT_UBOOTTOOLS}" | ||
79 | PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}" | 74 | PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}" |
80 | 75 | ||
81 | PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native" | 76 | PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native" |
diff --git a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb deleted file mode 100644 index d1e9512c..00000000 --- a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | require recipes-bsp/u-boot/u-boot-tools.inc | ||
2 | require u-boot-imx-common.inc | ||
3 | |||
4 | PROVIDES_append_class-target = " ${MLPREFIX}u-boot-tools" | ||
5 | PROVIDES_append_class-native = " u-boot-tools-native" | ||
6 | PROVIDES_append_class-nativesdk = " nativesdk-u-boot-tools" | ||
7 | |||
8 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
9 | |||
10 | # Set recipe as incompatible by default | ||
11 | COMPATIBLE_MACHINE = "(^$)" | ||
12 | |||
13 | # Whitelist its use for i.MX based machines | ||
14 | COMPATIBLE_MACHINE_use-mainline-bsp = "(.)" | ||
15 | COMPATIBLE_MACHINE_use-nxp-bsp = "(.)" | ||