summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-06-30 07:10:22 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-08-31 13:53:03 -0300
commit0d7046d70887f9276b33a45f003761e810eea648 (patch)
tree4f8bb0b58728c55dc5e06098d8cd38eba20193f3
parent28a3b754ba7689558f509390eea585bcd1f5520d (diff)
downloadmeta-freescale-0d7046d70887f9276b33a45f003761e810eea648.tar.gz
imx-atf: Remove -O2 from CFLAGS for 8MQ
The i.MX 8M Quad has only 64 kB of OCRAM, and the following build break is observed: ``` | aarch64-poky-linux-ld.bfd: /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-mx8m-fsl-linux/imx-atf/2.4+gitAUTOINC+ec35fef92b-r0/git/build-optee/imx8mq/release/bl31/bl31.elf section `coherent_ram' will not fit in region `RAM' | aarch64-poky-linux-ld.bfd: BL31 image has exceeded its limit. | aarch64-poky-linux-ld.bfd: region `RAM' overflowed by 4096 bytes ``` Fix the break by disabling -O2 optimization. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index 26b9e7d1..f4db002b 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -27,6 +27,8 @@ EXTRA_OEMAKE += " \
27 27
28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
29 29
30CFLAGS_remove_mx8mq = "-O2"
31
30do_compile() { 32do_compile() {
31 # Clear LDFLAGS to avoid the option -Wl recognize issue 33 # Clear LDFLAGS to avoid the option -Wl recognize issue
32 unset LDFLAGS 34 unset LDFLAGS