summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2020-12-01 16:53:45 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-17 11:07:12 -0300
commitde1e47a2e18096b4b70e24a0ae4429a15e5fe251 (patch)
treed19008da1a1ba2bec34f56763c74c1539e25601d
parent646ce62bea2246896b226e728c5df590151ff004 (diff)
downloadmeta-freescale-de1e47a2e18096b4b70e24a0ae4429a15e5fe251.tar.gz
optee-test_3.7.0.imx: fix optee-test build
Currently nothing is built for optee-test which means do_install() fails copying xtest binary. Align the do_compile() with upstream meta-arm optee-test recipe. With this patch the build then completes OK. Fixes: a66dc98 Signed-off-by: Peter Griffin <peter.griffin@linaro.org> (cherry picked from commit 840176462b2ae175bc06322f32c21d5b117b673e)
-rw-r--r--recipes-security/optee-imx/optee-test_3.7.0.imx.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.7.0.imx.bb b/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
index 04240ff0..e0dfdbe2 100644
--- a/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.7.0.imx.bb
@@ -39,6 +39,13 @@ EXTRA_OEMAKE = " \
39 OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ \ 39 OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}/ \
40 -C ${S} O=${B} \ 40 -C ${S} O=${B} \
41" 41"
42do_compile() {
43 cd ${S}
44 # Top level makefile doesn't seem to handle parallel make gracefully
45 oe_runmake xtest
46 oe_runmake ta
47}
48do_compile[cleandirs] = "${B}"
42 49
43do_install () { 50do_install () {
44 install -d ${D}/usr/bin 51 install -d ${D}/usr/bin