summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-01-22 16:25:50 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 16:48:43 -0300
commit9a6fe76e6509e8e23a16587f747d915a22f8305f (patch)
tree9c95f6b4776075bbf08c789116aaee17a55304a6
parent03fa40114dd1f1a4d79c672a6f3cbf3eae1e2077 (diff)
downloadmeta-freescale-9a6fe76e6509e8e23a16587f747d915a22f8305f.tar.gz
mesa: Limit OSMesa to DRM and remove swrast
OSMesa was originally added for i.MX 8 only. This limitation was recently dropped accidentally. Additionally, the 8DualXLite has no GPU and fails to build: ``` | In file included from ../../../mesa-demos-8.4.0/src/osdemos/osdemo32.c:14: | ../../../mesa-demos-8.4.0/src/util/glut_wrap.h:9:12: fatal error: GL/glut.h: No such file or directory | 9 | # include <GL/glut.h> | | ^~~~~~~~~~~ | compilation terminated. ``` Fix the OSMesa configuration by limiting it to parts with DRM. Also, adding swrast prevents the use of hardware acceleration. Drop swrast. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 47394d05017483e7fd0cba5b927c76198bdfa062)
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 6b9b456c..3a087425 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,10 +17,9 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# Enable OSMesa which also requires dri (classic) swrast 20# For NXP BSP, enable OSMesa for parts with DRM
21PACKAGECONFIG_remove_use-nxp-bsp = "gallium" 21PACKAGECONFIG_remove_use-nxp-bsp_imxdrm = "gallium"
22PACKAGECONFIG_append_use-nxp-bsp = " osmesa" 22PACKAGECONFIG_append_use-nxp-bsp_imxdrm = " osmesa"
23DRIDRIVERS_use-nxp-bsp = "swrast"
24 23
25BACKEND = \ 24BACKEND = \
26 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 25 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \