summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2021-04-14 16:24:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2021-05-14 17:47:00 -0300
commit6314f1927ca67cbf67cd8ce359518bf7fddd9ea7 (patch)
tree27cdb26b1d32f623872314d0f73f8c24ea338eba
parent99caa43b6b5ad3e4d19cb8e8aef329bdeabdd09d (diff)
downloadmeta-freescale-6314f1927ca67cbf67cd8ce359518bf7fddd9ea7.tar.gz
weston-init: Do not exit with error if uncomment function fail
Show a warning instead of raising an error when uncomment function can't found the text. This allows using a custom weston.ini file in bbappend. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> (cherry picked from commit 258063936a4256a40ba55bc2305c9989ef09598e)
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 22ffb7ff..66e148c1 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -41,7 +41,7 @@ INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \
41 41
42uncomment() { 42uncomment() {
43 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then 43 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then
44 bbfatal "Commented setting '#$1' not found in file $2" 44 bbwarn "Commented setting '#$1' not found in file $2"
45 fi 45 fi
46 sed -i -e 's,^#'"$1"','"$1"',g' $2 46 sed -i -e 's,^#'"$1"','"$1"',g' $2
47} 47}