summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-12-09 21:15:59 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 16:48:43 -0300
commit620e8ba1af9557aa55e06906c030144e8d390d48 (patch)
tree1def983849b3bf78a67f3823539225ee20e96113
parent8d141c7315f365c42af0c1c19728acdc93860adc (diff)
downloadmeta-freescale-620e8ba1af9557aa55e06906c030144e8d390d48.tar.gz
linux-fslc-imx: update to v5.4.82
Kernel repository has been upgraded to v5.4.82 from stable korg. Following upstream commits are included in this version: ---- ec274ecd62f9 Linux 5.4.82 4460a7c979ee RDMA/i40iw: Address an mmap handler exploit in i40iw 07434172c58b tracing: Remove WARN_ON in start_thread() 6ad995b851cb Input: i8042 - add ByteSpeed touchpad to noloop table dfe5d9a8307e Input: xpad - support Ardwiino Controllers c38a7023c00a ALSA: usb-audio: US16x08: fix value count for level meters 8cd76dacd3dc net/mlx5: Fix wrong address reclaim when command interface is down 2598dd80b801 net/mlx5: DR, Proper handling of unsupported Connect-X6DX SW steering 8f92330b0873 net/sched: act_mpls: ensure LSE is pullable before reading it 1086f789060a net: openvswitch: ensure LSE is pullable before reading it ba203b92a829 net: skbuff: ensure LSE is pullable before decrementing the MPLS ttl 892e08e0b4f3 net: mvpp2: Fix error return code in mvpp2_open() 7c3894f695e4 chelsio/chtls: fix a double free in chtls_setkey() 178da08f9b5b vxlan: fix error return code in __vxlan_dev_create() 5405a299b8c1 net: pasemi: fix error return code in pasemi_mac_open() dc469f423654 cxgb3: fix error return code in t3_sge_alloc_qset() 8bfe5b73b185 net/x25: prevent a couple of overflows 187a6daf5db4 net: ip6_gre: set dev->hard_header_len when using header_ops a6cd76132872 geneve: pull IP header before ECN decapsulation 2b714b607f24 inet_ecn: Fix endianness of checksum update when setting ECT(1) 9a3cce1ceee4 ibmvnic: Fix TX completion error handling 40caea31dd56 ibmvnic: Ensure that SCRQ entry reads are correctly ordered d126c30eb30d chelsio/chtls: fix panic during unload reload chtls 8a1bb298f75f dt-bindings: net: correct interrupt flags in examples af0b082e16fb ipv4: Fix tos mask in inet_rtm_getroute() 4615228a50f9 netfilter: bridge: reset skb->pkt_type after NF_INET_POST_ROUTING traversal 294de8933adb sched/fair: Fix unthrottle_cfs_rq() for leaf_cfs_rq list c4405cdf96f4 ima: extend boot_aggregate with kernel measurements 733729d3e0e4 staging/octeon: fix up merge error 6dd37fdc9550 bonding: wait for sysfs kobject destruction before freeing struct slave beead010654d usbnet: ipheth: fix connectivity with iOS 14 f057c4d226f1 tun: honor IOCB_NOWAIT flag 538008749df2 tcp: Set INET_ECN_xmit configuration in tcp_reinit_congestion_control 9a62c8229cff sock: set sk_err to ee_errno on dequeue from errq 7f0ddd41e289 rose: Fix Null pointer dereference in rose_send_frame() f2f25bc79782 net/tls: Protect from calling tls_dev_del for TLS RX twice a6300aedf862 net/tls: missing received data after fast remote close a15beea80e72 net/af_iucv: set correct sk_protocol for child sockets 9414855a1305 ipv6: addrlabel: fix possible memory leak in ip6addrlbl_net_init 99b5382bffd5 devlink: Hold rtnl lock while reading netdev attributes ---- Link: https://lore.kernel.org/r/20201206111554.677764505@linuxfoundation.org Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
index 2395dd43..24686195 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v5.4.81 31# tag: v5.4.82
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -73,14 +73,14 @@ LICENSE = "GPLv2"
73LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 73LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
74 74
75SRCBRANCH = "5.4-2.1.x-imx" 75SRCBRANCH = "5.4-2.1.x-imx"
76SRCREV = "22c6803f24b654d5b681cd90e516ca54262ed6c9" 76SRCREV = "e7d7739c920d256d842d79959a3447f69d378050"
77 77
78# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 78# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
79# required by kernel-yocto.bbclass. 79# required by kernel-yocto.bbclass.
80# 80#
81# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 81# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
82# should be updated once patchlevel is merged. 82# should be updated once patchlevel is merged.
83LINUX_VERSION = "5.4.81" 83LINUX_VERSION = "5.4.82"
84 84
85# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 85# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
86LOCALVERSION = "-imx-5.4.24-2.1.0" 86LOCALVERSION = "-imx-5.4.24-2.1.0"