summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-02 12:15:45 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 16:48:43 -0300
commit2f9dcf62d3b7058193658efb352423c15cee1b0e (patch)
tree9ba107ea6a3a6e0e3918bba90fc69369087e00b0
parent1aff2e34a84573d8d4f8a36561c99c8540ae5b1a (diff)
downloadmeta-freescale-2f9dcf62d3b7058193658efb352423c15cee1b0e.tar.gz
mesa: Disable dri for parts without DRM
On dunfell mesa build breaks with dri enabled: ``` | meson.build:455:4: ERROR: Problem encountered: building dri drivers require at least one windowing system or classic osmesa ``` The break does not occur on master since dri is disabled if no dri drivers are configured. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 4f38acd9..b6dbcc2f 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,10 +17,15 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# For NXP BSP, enable OSMesa for parts with DRM 20# For NXP BSP, disable dri for parts without DRM.
21# Also enable swrast for its dri driver 21# Disable gallium and enable OSMesa for parts with DRM.
22PACKAGECONFIG_remove_use-nxp-bsp_imxdrm = "gallium" 22# Also enable swrast for its dri driver for parts with DRM.
23PACKAGECONFIG_append_use-nxp-bsp_imxdrm = " osmesa" 23PACKAGECONFIG_REMOVE_NXPBSP = "dri"
24PACKAGECONFIG_APPEND_NXPBSP = ""
25PACKAGECONFIG_REMOVE_NXPBSP_imxdrm = "gallium"
26PACKAGECONFIG_APPEND_NXPBSP_imxdrm = "osmesa"
27PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
28PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
24DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast" 29DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast"
25 30
26BACKEND = \ 31BACKEND = \