summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2020-10-18 13:50:29 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2021-05-31 21:59:20 -0300
commit2bbd0e56185bef1a3189887b80c6c04136ed2a18 (patch)
tree7bb84e047fe0868d838d68d433caf29f2960e630
parentde5c141933dfb685bdb98ddfd4d5bd989cdcbb6b (diff)
downloadmeta-freescale-2bbd0e56185bef1a3189887b80c6c04136ed2a18.tar.gz
libimxvpuapi2: Update to version 2.1.0
* introduce RGB and packed YUV formats since the Hantro encoder supports those * remove hardware specific public headers since they only added tiled pixel formats; instead, migrate these tiled formats into ImxVpuApiColorFormat * imx8 hantro decoder: reorder list of supported decoder color formats to favor 10 bit output * imx8 hantro decoder: clear new framebuffer fields to zero * imx8 hantro encoder: fix segfault caused by trying to unmap non existing staged raw frame Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org> (cherry picked from commit aa3189ea5c91eb8c0947474abaf983bcdecc017a)
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.1.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.1.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.1.0.bb
new file mode 100644
index 00000000..f6b4baae
--- /dev/null
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.1.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "frontend for the i.MX6 / i.MX8 VPU hardware video engines"
2HOMEPAGE = "https://github.com/Freescale/libimxvpuapi"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia"
6DEPENDS = "virtual/imxvpu libimxdmabuffer"
7
8PV .= "+git${SRCPV}"
9
10SRCBRANCH ?= "master"
11SRCREV = "49cb1b34d759aa7a51269ca0f58fcc1f9647da5b"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH}"
13
14S = "${WORKDIR}/git"
15
16inherit waf pkgconfig use-imx-headers
17
18IMX_PLATFORM_mx6 = "imx6"
19IMX_PLATFORM_mx8mq = "imx8m"
20IMX_PLATFORM_mx8mm = "imx8mm"
21IMX_PLATFORM_mx8mp = "imx8mm"
22
23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26COMPATIBLE_MACHINE = "(imxvpu)"