summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Dimich <Chris.Dimich@boundarydevices.com>2021-03-08 15:17:11 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2021-03-10 16:42:53 -0300
commit1acf098972f9f86b26eee815827667dbd2fcdeaf (patch)
tree925cbb1fddd58de755942a3c457b54a2398ff1d7
parentd9076551107cfe960cb3c8861a756d35e4e99a0f (diff)
downloadmeta-freescale-1acf098972f9f86b26eee815827667dbd2fcdeaf.tar.gz
imx-vpu-hantro-vc: add do_install function
The encoding library was not previously being installed. Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com> (cherry picked from commit 0a435d64e588843f6943d6e5723e5ecc12990aa2)
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.2.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.2.0.bb
index a38d064f..8414e53e 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.2.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.2.0.bb
@@ -13,4 +13,23 @@ S = "${WORKDIR}/${BPN}-${PV}"
13SRC_URI[md5sum] = "d2b7c0cfdb380e5a65a94251c2437a34" 13SRC_URI[md5sum] = "d2b7c0cfdb380e5a65a94251c2437a34"
14SRC_URI[sha256sum] = "10a7f60964feb9641291815876fb8110dfec603c6451ed9b9c7fe57c23afd10e" 14SRC_URI[sha256sum] = "10a7f60964feb9641291815876fb8110dfec603c6451ed9b9c7fe57c23afd10e"
15 15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES_${PN} = "/"
34
16COMPATIBLE_MACHINE = "(mx8mp)" 35COMPATIBLE_MACHINE = "(mx8mp)"