diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2018-07-23 22:13:19 +0200 |
---|---|---|
committer | Fabio Berton <fabio.berton@ossystems.com.br> | 2018-07-30 10:42:46 -0300 |
commit | 040e4f031f2dc581c48253405da9036def035b68 (patch) | |
tree | 629f23aa60de7b14bc11af619dfed40d10ff7b86 | |
parent | fd89a85eaafb4f26a11d96db5702eadb83c02813 (diff) | |
download | meta-freescale-040e4f031f2dc581c48253405da9036def035b68.tar.gz |
dtc-145: Deploy renamed binary only and add new class
dtc-145-native is used by older U-Boot recipes. U-Boot only depends on
the native dtc binary. So, to not clash with files from the regular dtc native
build do only install the dtc binary renamed to dtc-145. Also, create
a new class to handle with dtc-145 dependency.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
-rw-r--r-- | classes/dtc-145.bbclass | 7 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2017.03.bb | 3 | ||||
-rw-r--r-- | recipes-kernel/dtc/dtc-145_git.bb | 6 |
3 files changed, 14 insertions, 2 deletions
diff --git a/classes/dtc-145.bbclass b/classes/dtc-145.bbclass new file mode 100644 index 00000000..d4a30711 --- /dev/null +++ b/classes/dtc-145.bbclass | |||
@@ -0,0 +1,7 @@ | |||
1 | # Use this class for U-Boot 2017.03 or older. | ||
2 | |||
3 | DEPENDS_append = " dtc-145-native" | ||
4 | |||
5 | do_configure_prepend () { | ||
6 | sed -i -e 's/^DTC[[:space:]]*=[[:space:]]*dtc[[:space:]]*$/DTC = dtc-145/' ${S}/Makefile | ||
7 | } | ||
diff --git a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb index 52ebee99..0e4ba7b3 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2017.03.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2017.03.bb | |||
@@ -6,7 +6,6 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards." | |||
6 | require recipes-bsp/u-boot/u-boot.inc | 6 | require recipes-bsp/u-boot/u-boot.inc |
7 | 7 | ||
8 | PROVIDES += "u-boot" | 8 | PROVIDES += "u-boot" |
9 | DEPENDS_append = "dtc-145-native" | ||
10 | 9 | ||
11 | LICENSE = "GPLv2+" | 10 | LICENSE = "GPLv2+" |
12 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 11 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
@@ -17,7 +16,7 @@ SRCREV = "b76bb1bf9fd21e21006d79552e28855ac43ad43c" | |||
17 | 16 | ||
18 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
19 | 18 | ||
20 | inherit fsl-u-boot-localversion | 19 | inherit dtc-145 fsl-u-boot-localversion |
21 | 20 | ||
22 | LOCALVERSION ?= "-${SRCBRANCH}" | 21 | LOCALVERSION ?= "-${SRCBRANCH}" |
23 | 22 | ||
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb index afed62fd..2776cc5e 100644 --- a/recipes-kernel/dtc/dtc-145_git.bb +++ b/recipes-kernel/dtc/dtc-145_git.bb | |||
@@ -10,3 +10,9 @@ SRCREV = "22a65c5331c22979d416738eb756b9541672e00d" | |||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | 11 | ||
12 | BBCLASSEXTEND = "native nativesdk" | 12 | BBCLASSEXTEND = "native nativesdk" |
13 | |||
14 | # only install the dtc binary renamed to dtc-145 | ||
15 | do_install () { | ||
16 | install -d ${D}/${bindir} | ||
17 | install -m 755 dtc ${D}/${bindir}/dtc-145 | ||
18 | } | ||