summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2020-12-11 17:44:34 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 16:48:43 -0300
commit03fa40114dd1f1a4d79c672a6f3cbf3eae1e2077 (patch)
tree1a417346b17719defa38ee14c05743c4acac3cd4
parentffc8378a52c9b3006d2dc27ea115e8673831b90b (diff)
downloadmeta-freescale-03fa40114dd1f1a4d79c672a6f3cbf3eae1e2077.tar.gz
mesa: Use OSMesa for use-nxp-bsp
Enabling OSMesa and disabling Gallium is needed when using use-nxp-bsp, if we don't do this mesa raises error: Problem encountered: building dri drivers require at least one windowing system or classic osmesa Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> (cherry picked from commit 3b0fc734634f8f0db1f48fc13c64cacd3d99dd92)
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend13
1 files changed, 3 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 8d429abf..6b9b456c 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,17 +17,10 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20USE_OSMESA_ONLY ?= "no"
21
22# Etnaviv support state for i.MX8 is unknown, therefore only enable OSMesa and
23# disable Gallium for now. If you still want to enable Etnaviv, just set
24# USE_OSMESA_ONLY_mx8 = "no" in your bbappend.
25USE_OSMESA_ONLY_mx8 ?= "yes"
26
27# Enable OSMesa which also requires dri (classic) swrast 20# Enable OSMesa which also requires dri (classic) swrast
28PACKAGECONFIG_append = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', ' osmesa', '', d)}" 21PACKAGECONFIG_remove_use-nxp-bsp = "gallium"
29PACKAGECONFIG_remove = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'gallium', '', d)}" 22PACKAGECONFIG_append_use-nxp-bsp = " osmesa"
30DRIDRIVERS_append = "${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'swrast', '', d)}" 23DRIDRIVERS_use-nxp-bsp = "swrast"
31 24
32BACKEND = \ 25BACKEND = \
33 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 26 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \