summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-12-16 08:00:54 -0300
committerGitHub <noreply@github.com>2022-12-16 08:00:54 -0300
commitf5e016f5220d0cf2b3364725e4706a4766d7073a (patch)
treebc4d762d8930020db4788debfaf2d1f4f7aa7854
parentebe0e15e8fe5f606af78ffa89f7b859e1b6e1bb6 (diff)
parenta33bd36190f7bb729f3d17274b9f677e1d1473e4 (diff)
downloadmeta-freescale-f5e016f5220d0cf2b3364725e4706a4766d7073a.tar.gz
Merge pull request #1333 from junzhuimx/master
Upgrade MC/mc-util and restool
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb2
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.35.0.bb41
-rw-r--r--recipes-dpaa2/restool/restool_git.bb2
3 files changed, 43 insertions, 2 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
index 90992c18..fc0486e0 100644
--- a/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -8,7 +8,7 @@ DEPENDS += "dtc-native"
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://github.com/nxp-qoriq/mc-utils;protocol=https;nobranch=1" 10SRC_URI = "git://github.com/nxp-qoriq/mc-utils;protocol=https;nobranch=1"
11SRCREV = "12ffee82d210cb6b5c8fa30fbc6f5d29e4be2e6f" 11SRCREV = "bc141334051a2e1e3ea2f4eedee8e1165d52e4a5"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
diff --git a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb b/recipes-dpaa2/management-complex/management-complex_10.35.0.bb
new file mode 100644
index 00000000..d114a92e
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.35.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=1db1363924ceccb1edea921b6495bdc2"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1"
10SRCREV = "836d7bf606b51c18b5e3726d68dcf3b3ac4de74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 30515ecf..3af4b8aa 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
5SRC_URI = "git://github.com/nxp-qoriq/restool;protocol=https;nobranch=1 \ 5SRC_URI = "git://github.com/nxp-qoriq/restool;protocol=https;nobranch=1 \
6 file://disable-manpage-generation.patch \ 6 file://disable-manpage-generation.patch \
7" 7"
8SRCREV = "d29522aef9f92ff2557978d5d3979b771a9576fe" 8SRCREV = "65c9a10d95b19e61d2f86dbcaa45d12ba98e85e1"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11