summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-05-18 07:15:49 -0300
committerGitHub <noreply@github.com>2022-05-18 07:15:49 -0300
commitac914d2f258dbda817f491619de91a011a588918 (patch)
treecb12fe40346dc56e6b090e6ca1ebc9b4ff2ae365
parentbad9e496d04a72f443a06c33f4805ec9ec7bc79e (diff)
parent1d9eb0fc2443414014be964b6353710439be5226 (diff)
downloadmeta-freescale-ac914d2f258dbda817f491619de91a011a588918.tar.gz
Merge pull request #1092 from thochstein/optee
Optee arch small rework
-rw-r--r--recipes-security/optee-imx/optee-os_3.15.0.imx.bb3
-rw-r--r--recipes-security/optee-imx/optee-test_3.15.0.imx.bb8
2 files changed, 3 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
index 15244c45..6d10b93d 100644
--- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb
@@ -40,8 +40,7 @@ PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek"
40PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" 40PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk"
41PLATFORM_FLAVOR:mx8ulp-nxp-bsp = "mx8ulpevk" 41PLATFORM_FLAVOR:mx8ulp-nxp-bsp = "mx8ulpevk"
42 42
43OPTEE_ARCH ?= "arm32" 43OPTEE_ARCH:arm = "arm32"
44OPTEE_ARCH:armv7a = "arm32"
45OPTEE_ARCH:aarch64 = "arm64" 44OPTEE_ARCH:aarch64 = "arm64"
46 45
47# Optee-os can be built for 32 bits and 64 bits at the same time 46# Optee-os can be built for 32 bits and 64 bits at the same time
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
index a44454a7..a3649d74 100644
--- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb
@@ -21,18 +21,14 @@ inherit python3native features_check
21 21
22REQUIRED_MACHINE_FEATURES = "optee" 22REQUIRED_MACHINE_FEATURES = "optee"
23 23
24OPTEE_ARCH ?= "arm32" 24OPTEE_ARCH:arm = "arm32"
25OPTEE_ARCH:armv7a = "arm32"
26OPTEE_ARCH:aarch64 = "arm64" 25OPTEE_ARCH:aarch64 = "arm64"
27 26
28TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/"
29TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/"
30
31CFLAGS += "--sysroot=${STAGING_DIR_HOST}" 27CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
32CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" 28CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
33 29
34EXTRA_OEMAKE = " \ 30EXTRA_OEMAKE = " \
35 TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ 31 TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \
36 ARCH=${OPTEE_ARCH} \ 32 ARCH=${OPTEE_ARCH} \
37 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ 33 OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \
38 CROSS_COMPILE_HOST=${HOST_PREFIX} \ 34 CROSS_COMPILE_HOST=${HOST_PREFIX} \