summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-02-01 18:14:33 -0300
committerGitHub <noreply@github.com>2023-02-01 18:14:33 -0300
commit9024c90df68ae97d3a6f8decaa513cce7a8c2c5b (patch)
tree639944ae03d956def6ae06d4bfdf628ba2cec03e
parentfce8af0b0742fbeb0fd000912d54a615f8909351 (diff)
parent6aa285dc90bca57414d1b616e66ed91d4d97c8db (diff)
downloadmeta-freescale-9024c90df68ae97d3a6f8decaa513cce7a8c2c5b.tar.gz
Merge pull request #1393 from mdrodrigo/topic/u-boot-fix
Fix u-boot-fscl-mxsboot
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.01.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.01.bb
index a7dfd8aa..b7e4ca76 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.01.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.01.bb
@@ -3,7 +3,17 @@ require u-boot-fslc-common_${PV}.inc
3DESCRIPTION = "U-boot bootloader mxsboot tool" 3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader" 4SECTION = "bootloader"
5 5
6DEPENDS = "swig-native bison-native gnutls-native dtc openssl" 6inherit python3native
7
8DEPENDS += " \
9 bison-native \
10 dtc \
11 gnutls \
12 openssl \
13 python3-setuptools-native \
14 swig-native \
15 util-linux-libuuid \
16"
7 17
8PROVIDES = "u-boot-mxsboot" 18PROVIDES = "u-boot-mxsboot"
9 19
@@ -12,7 +22,7 @@ EXTRA_OEMAKE:class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" H
12EXTRA_OEMAKE:class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' 22EXTRA_OEMAKE:class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
13 23
14do_compile () { 24do_compile () {
15 oe_runmake -C ${S} O=${B} sandbox_defconfig 25 oe_runmake -C ${S} O=${B} tools-only_defconfig
16 26
17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and 27 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
18 # generating it requires bin2header tool, which for target build 28 # generating it requires bin2header tool, which for target build