summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2023-07-30 13:48:05 +0200
committerCarlos Rafael Giani <crg7475@mailbox.org>2023-07-30 16:58:47 +0200
commitfa1d6477c9d276a9d39a55906fafaf0f8f4ec29f (patch)
tree0c6ea70e6f8f60574da6384e7a6b49f52d00e83a
parent5494d046d3442e31cadfe11b614d020028eada29 (diff)
downloadmeta-freescale-fa1d6477c9d276a9d39a55906fafaf0f8f4ec29f.tar.gz
libimxdmabuffer: Upgrade to version 1.1.3
* waf: update to 2.0.25 * g2d: Fix typo in G2D allocator that caused build errors * Don't check for mxcfb.h in build script mxcfb.h is no longer present in some sysroots anymore, so it is not a reliable way for verifying the imx linux headers path. Just use the path directly; if it is wrong, the build will fail anyway. Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
-rw-r--r--recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch28
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb (renamed from recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb)3
2 files changed, 1 insertions, 30 deletions
diff --git a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
deleted file mode 100644
index 490d3a2f..00000000
--- a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 41825b11289be251fed64470893d18b89b0dd38b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <crg7475@mailbox.org>
3Date: Sun, 8 May 2022 16:25:44 +0200
4Subject: [PATCH] g2d: Fix typo
5
6Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
7
8Upstream-Status: Backport [41825b11289be251fed64470893d18b89b0dd38b]
9---
10 imxdmabuffer/imxdmabuffer_g2d_allocator.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/imxdmabuffer/imxdmabuffer_g2d_allocator.c b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
14index f10a909..497dcea 100644
15--- a/imxdmabuffer/imxdmabuffer_g2d_allocator.c
16+++ b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
17@@ -139,7 +139,7 @@ static uint8_t* imx_dma_buffer_g2d_allocator_map(ImxDmaBufferAllocator *allocato
18 * (Other allocators perform more steps than this.) */
19 if (imx_g2d_buffer->mapping_refcount > 0)
20 {
21- assert((imx_dwl_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
22+ assert((imx_g2d_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
23 imx_g2d_buffer->mapping_refcount++;
24 }
25 else
26--
272.32.0
28
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
index dd3b65da..bc40a1cf 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
@@ -8,9 +8,8 @@ SECTION = "base"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "5410b44fb0c5bbd9fb1f3ba0681e65068d8cde57" 11SRCREV = "faf547cc2345bfbf95507ab7e86530f85289bb5b"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://0001-g2d-Fix-typo.patch \
14 file://run-ptest \ 13 file://run-ptest \
15 " 14 "
16 15