summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-09-21 10:19:51 +0000
committerAndrey Zhizhikin <andrey.z@gmail.com>2021-09-21 10:19:51 +0000
commitcaf31d5cd5adba3d53cbc4a4da407771965c8f25 (patch)
treecf0a650eccb4670ca7f1c10fc6709057354822d6
parent4658c45c1d6aa72e0cb45dcc6f9572653b5be706 (diff)
downloadmeta-freescale-caf31d5cd5adba3d53cbc4a4da407771965c8f25.tar.gz
linux-fslc-imx: update to v5.4.129
Kernel repository has been upgraded up to v5.4.129 from stable korg. Following upstream commits are included in this version: ---- 82ffbc138a1f Linux 5.4.129 9011aaab90b8 certs: Move load_system_certificate_list to a common function e20b90e4f81b certs: Add EFI_CERT_X509_GUID support for dbx entries 06ab9df09eb3 x86/efi: move common keyring handler functions to new file ac7d3f554472 certs: Add wrapper function to check blacklisted binary hash 61168eafe024 mm, futex: fix shared futex pgoff on shmem huge page a33b70d62552 mm/thp: another PVMW_SYNC fix in page_vma_mapped_walk() e045e9e79d2a mm/thp: fix page_vma_mapped_walk() if THP mapped by ptes 037a1d67d236 mm: page_vma_mapped_walk(): get vma_address_end() earlier fa89d536948a mm: page_vma_mapped_walk(): use goto instead of while (1) a499febd9935 mm: page_vma_mapped_walk(): add a level of indentation b1783bf8c8e4 mm: page_vma_mapped_walk(): crossing page table boundary 80b2270a14b8 mm: page_vma_mapped_walk(): prettify PVMW_MIGRATION block ef161ccaca70 mm: page_vma_mapped_walk(): use pmde for *pvmw->pmd 4961160272b7 mm: page_vma_mapped_walk(): settle PageHuge on entry 52e2b20fb5e4 mm: page_vma_mapped_walk(): use page for pvmw->page 82ee7326af7a mm: thp: replace DEBUG_VM BUG with VM_WARN when unmap fails for split bd4389215227 mm/thp: unmap_mapping_page() to fix THP truncate_cleanup_page() b767134ec30a mm/thp: fix page_address_in_vma() on file THP tails 41432a8a6776 mm/thp: fix vma_address() if virtual address below file offset 4b0a34e222e5 mm/thp: try_to_unmap() use TTU_SYNC for safe splitting bd092a0f1942 mm/thp: make is_huge_zero_pmd() safe and quicker 4c37d7f269f8 mm/thp: fix __split_huge_pmd_locked() on shmem migration entry 7ce4b73d349b mm, thp: use head page in __migration_entry_wait() 68ce37ebe0f2 mm/rmap: use page_not_mapped in try_to_unmap() 432b61863ac7 mm/rmap: remove unneeded semicolon in page_not_mapped() cfe575954ddd mm: add VM_WARN_ON_ONCE_PAGE() macro 42f11f0fe977 kthread: prevent deadlock when kthread_mod_delayed_work() races with kthread_cancel_delayed_work_sync() 06ab015d1849 kthread_worker: split code for canceling the delayed work timer d77c9c8537db i2c: robotfuzz-osif: fix control-request directions bb85717e3797 KVM: do not allow mapping valid but non-reference-counted pages d6f751ecccfb nilfs2: fix memory leak in nilfs_sysfs_delete_device_group 702acfcbfa68 pinctrl: stm32: fix the reported number of GPIO lines per bank 76c10e10ba7b net: ll_temac: Avoid ndo_start_xmit returning NETDEV_TX_BUSY aa00b9780482 net: ll_temac: Add memory-barriers for TX BD access d807b93f9bca PCI: Add AMD RS690 quirk to enable 64-bit DMA 5830f2081d98 recordmcount: Correct st_shndx handling 70866199220e net: qed: Fix memcpy() overflow of qed_dcbx_params() b7168ec176fd KVM: selftests: Fix kvm_check_cap() assertion 58687d143515 r8169: Avoid memcpy() over-reading of ETH_SS_STATS cb4a2e4e224a sh_eth: Avoid memcpy() over-reading of ETH_SS_STATS 97e0102e1824 r8152: Avoid memcpy() over-reading of ETH_SS_STATS f12a5b48bcc8 net/packet: annotate accesses to po->ifindex cdcedd3c8683 net/packet: annotate accesses to po->bind 343406f9c198 net: caif: fix memory leak in ldisc_open 8707ce86e927 net: phy: dp83867: perform soft reset and retain established link 9f2d04dfb3c4 inet: annotate date races around sk->sk_txhash d40ff07a7b7d ping: Check return value of function 'ping_queue_rcv_skb' 9df4f031536b net: ethtool: clear heap allocations for ethtool function 62aed2df294a mac80211: drop multicast fragments eb2b1216bc8f net: ipv4: Remove unneed BUG() function e0c950d2fddb dmaengine: mediatek: use GFP_NOWAIT instead of GFP_ATOMIC in prep_dma f7b1926c7c5d dmaengine: mediatek: do not issue a new desc if one is still current 3d995587c3ea dmaengine: mediatek: free the proper desc in desc_free handler c09af3877b53 dmaengine: rcar-dmac: Fix PM reference leak in rcar_dmac_probe() f2c027a7750f cfg80211: call cfg80211_leave_ocb when switching away from OCB 78bf3c613148 mac80211_hwsim: drop pending frames on stop ae9de9444b54 mac80211: remove warning in ieee80211_get_sband() 0e486713779a dmaengine: zynqmp_dma: Fix PM reference leak in zynqmp_dma_alloc_chan_resourc() 456367b24190 Revert "PCI: PM: Do not read power state in pci_enable_device_flags()" 1442186236ad spi: spi-nxp-fspi: move the register operation after the clock enable 7bc73260c4b1 MIPS: generic: Update node names to avoid unit addresses 0855fe6d8835 arm64: link with -z norelro for LLD or aarch64-elf 3173390b8dbc kbuild: add CONFIG_LD_IS_LLD 3450f5eb8c9e mmc: meson-gx: use memcpy_to/fromio for dram-access-quirk 48a5449c0be1 ARM: 9081/1: fix gcc-10 thumb2-kernel regression 4a8e89e0fd0b drm/radeon: wait for moving fence after pinning 4577708b2a22 drm/nouveau: wait for moving fence after pinning v2 c77c617e26e2 Revert "drm/amdgpu/gfx10: enlarge CP_MEC_DOORBELL_RANGE_UPPER to cover full doorbell." 6bd0da6c9b12 Revert "drm/amdgpu/gfx9: fix the doorbell missing when in CGPG issue." e2dc07ca4e01 module: limit enabling module.sig_enforce ---- Link: https://github.com/Freescale/linux-fslc/pull/387 Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
index 59fded5e..751a5ff2 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v5.4.128 31# tag: v5.4.129
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -73,14 +73,14 @@ LICENSE = "GPLv2"
73LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 73LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
74 74
75SRCBRANCH = "5.4-2.1.x-imx" 75SRCBRANCH = "5.4-2.1.x-imx"
76SRCREV = "e7915bcad4fbc1d94e1cb5e192c2738cd1b5c6f5" 76SRCREV = "a1abf8a38a8a8364171e432306dbf48249f742c9"
77 77
78# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 78# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
79# required by kernel-yocto.bbclass. 79# required by kernel-yocto.bbclass.
80# 80#
81# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 81# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
82# should be updated once patchlevel is merged. 82# should be updated once patchlevel is merged.
83LINUX_VERSION = "5.4.128" 83LINUX_VERSION = "5.4.129"
84 84
85# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 85# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
86LOCALVERSION = "-imx-5.4.24-2.1.0" 86LOCALVERSION = "-imx-5.4.24-2.1.0"